Best answer

FacebooK lead Form Not Pulling Through Pages - With New Update Cant Use Page ID?

  • 8 April 2020
  • 2 replies
  • 78 views

Ever since the UI update, I have been having major problems with Facebook Lead Gen forms.

The platform used to allow you to call a page by using the Page ID but now it does not.

A few of our pages (even some already running zaps) arent pulling through in the zap creation flow.

I have reset connections, cleared my cache, reached out to the client to set up lead access, verified that i am an admin on the page…. everything to no avail.

 

Is there still a way to force the page call through the page ID? Also, other than requesting lead access (which oddly enough I havent had to do for many other clients) what can I to to get the pages to pull through to Zapier?

icon

Best answer by steph.n 27 May 2020, 19:30

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +8

Hi there @NMendenhall - It’s been a while but we just wanted to say that it’s awesome that you were able to use the page ID to pull the form through. I understand that the configuration may have not changed, but what you did by reapplying all the settings and enabling the Zap again seems to have worked. Yay for functional Zaps!

I hope you don’t mind as we wish to share this answer with other users who maybe seeking it out. Thanks so much!

Userlevel 7
Badge +11

Hi Nathan!

Looks like you’ve got a great conversation going with our Support team and they’re helping you out with this! Please continue the conversation there, since they’re able to dig into your Zaps :)