Best answer

Zap not downloading Zoom meetings to Google Drive

I am creating a zap to automatically download my Zoom meetings into a Google Drive, but when I test it I just see a file with a bunch of number in the drive folder and no video. Help!


Best answer by SamB 22 May 2024, 17:37

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

19 replies

Userlevel 3
Badge +4

Hi @aomara 

Thanks for reaching out to the Community!

I’m sorry that you’re having issues with your Zap.

Before we dig deeper into this, could you send screenshots of how you’ve configured the steps of the Zap so far? That’ll help me make sure I give you the best suggestion possible.

(If there’s any personal information, kindly blur them.)

Looking forward to your response!


Userlevel 7
Badge +6

Hi @aomara,

I’m jumping in to see if I can help!

In order for these files from Zoom to be available in downstream steps (like Google Drive) you'll need to ensure that your Zoom settings need to be set correctly. You should be able to access those setting here:

Make sure that both the Only authenticated users can view cloud recordings and Require password to access shared cloud recordings settings are off:
(view larger)
As a note, this will also only work for new cloud recordings recorded after those options were set to off.

Also, make sure you're in the setting for Recordings instead of settings for Meetings. My understanding is that these appear very similar in wording in both menus, so just wanted to point that out.

Hopefully, this helps! 😊

@ken.a Thank you! I doubled checked my settings and those are both off. 

Userlevel 7
Badge +6

Hi @aomara,

Thanks for letting me know! One more thing, could you please ensure that the Only the host can download cloud recordings is unchecked:

Kindly go to Admin > Account Management > Account Settings > Recording > Cloud recording downloads.

Keep us posted! 😊

@ken.a I unchecked it, tested it and it’s still not uploading the video (just a weird file with a bunch of coding)

Is there something here I need to change? 


Userlevel 7
Badge +6

Hi @aomara,

Thank you for giving those a try.

I noticed that the “Allow cloud record sharing” is turned off. Could you please turn that on as well? Here are the additional instructions as per our notes:

What are all the settings required to be set to enable the download of the recording?


On the Zoom account connected to Zapier go to "Settings" -> "Recording":

On their admin Zoom account go to "Account Management" -> "Account Settings" -> "Recording":


Additionally, could you please do these for me as well?

  1. Go to your trigger step.
  2. Load in a recent sample data by clicking on “Load more”
  3. Now, on the Google Drive step, ensure that the mapped data on the “File” field is the “Video Files Download URL”
  4. Trigger the Zap again.

Please give those a try, and keep us posted.

Thanks! 😊

@ken.a Ok I did all that and it is still not working. Here are screenshots of my settings….


Userlevel 7
Badge +6

Hi there @aomara,

Unfortunately, it seems that I've reached the limit of my troubleshooting resources on this issue. I recommend that you get in touch with our Support team for further assistance, as they can examine the backend logs of the Zap and identify the root cause of the problem. To ensure that they can pick up where we left off, please share the link to this Community post with them.

You can contact our Support team by following this link:



Any updates on this?

Userlevel 7
Badge +11

Hi there @Cole Fortman, welcome to the Community! 👋

I did some checking on this end and couldn’t see a ticket from Aomara opened with our Support team about this. @aomara - were you since able to get the Zap working? If so, we’d love to hear how you were able to get this solved if you have a moment to share those details here. 🙂

@Cole Fortman - have you given the various troubleshooting steps suggested by Ken here a try? If so and they didn’t solve it things for you here either I’d recommend getting in touch with our Support Team. If it’s a bug they’ll be able to confirm that and open up a bug report for this. You can get in touch with them here:

Please do keep us updated here on how it goes! 

We have the same issue, we checked all the configuration on zoom and its ok. Any idea whats is going on?




Userlevel 7
Badge +11

Hi there @Babbage! Sorry to hear that you’re being impacted by this issue as well.

If none of the troubleshooting suggestions mentioned in this thread helped to solved things then I’d recommend reaching out to our Support team. They’ll be able to take a closer look at your Zap and the system logs to better investigate what might be causing the issue here.  

Please do keep us in the loop on how you get on with them! 

I’m having the same issue. I’ll reach out to the Support team.

Userlevel 7
Badge +11

Thanks for letting us know @brienna. I’m so sorry you’re being affected by this as well.

I’ve dug into the support discussions with @Babbage and it appears that they were able to resolve things contacting to Zoom who were able to make some changes on Zoom’s end to get things working. Might be worth reaching out to Zoom’s support team about this as well just in case they’re able to do the same for you too.

Please do let us know how you get on with this! 🙂

Thanks SamB!

I also tried switching the Google Drive task with an email task, and the emailed file was also a HTML file instead of a video.

I reached out to Zoom support, and it seems that because I can manually download the video using the Video Files Download URL, the problem lies with Zapier. I’m hoping to hear back from Zapier’s support team. 

Turns out I hadn’t done this step: 

  • Turn off "Require passcode to access shared cloud recordings."

The reason why I was able to manually download the file using the Video Files Download URL was because I was signed in. If I try pasting the URL into an incognito browser, it takes me to the password page.

I tested removing the passcode from an existing recording, and the Zap successfully uploaded it to Google Drive. The HTML page that I had been getting with other recordings was the password page, which you can tell if you see this in the doc: 

<title>Passcode Required - Zoom</title>

Unfortunately I’m required by my org to set a passcode on my cloud recordings. 

I wonder if Zapier has received an update on the Zoom feature request mentioned in this other thread?

In anticipation of some users requiring this to work for password-protected recordings, we’ve added Feature Request #111 to Zoom.


Userlevel 7
Badge +11

Thanks for following up here, @brienna. I’m so glad you were able to get to the bottom of what was preventing the uploads from working.

I’ve checked on that feature request and it’s still open. I’ve added your vote to that which will help to increase it’s priority but I’m unable to give any sort of timeline as to when it would become possible to access passcode protected Zoom recordings via Zapier. We’ll be sure to send you an email notification as soon as it’s been implemented.

In the meantime, is it possible to add a passcode to a recording after it’s been recorded? If so, I wonder if you could disable the “Require passcode to access shared cloud recordings.” setting and then add a passcode to the recording once it’s been uploaded? You may want to add an additional action to the Zap to send you a reminder you to add the passcode to that recording. Or could you move the recordings to a password protected folder on Zoom after the Zap has successfully uploaded it? Not ideal I know but hopefully helps to get your workflow up and running for now. 🤞

Userlevel 7
Badge +11

Hey folks,

Just circling back in here to share that the feature request has been closed. A new Find Recording and Download search action has been added to the latest version of the app, which will allow you to download recordings protected with passcode! 🎉

If you’re unable to see that new search action in your Zaps then you may need to upgrade the Zoom app on Zapier to the latest version - see our Update to the latest app version in Zaps guide for details on how to do that.

We hope you’re able to try it out soon and if you run into any issues with it please let us know in the Community or get in touch with Support directly

​​​​​​​In the meantime, happy Zapping! ⚡