Salesforce error: “This auth is expired. Please reconnect it here.”

  • 20 May 2024
  • 4 replies

Userlevel 1

I keep getting this error: “This auth is expired. Please reconnect it here.”

  1. I go to reconnect and I follow the prompts, “Connect to production”  “Yes continue to Salesforce” it takes me to the salesforce log in page, I log into Salesforce, then it takes me to the “allow Access” page and I click “allow” then it takes me back to the Zap I am working on, then I get the same message “This auth is expired. Please reconnect it here.”
  2. I opened a support ticket with Zapier and I have not received an reply yet.
  3. I see other community members have had the same issue with this particular error but I don’t see it resolved.
  4. I follow the steps on this article: “
  5. I followed the steps on this article:

I don’t know what else to do to complete the connection. Any insight or advice will be greatly appreciated.


Miriam Hoebel

Salesforce Associate Administrator

4 replies

Userlevel 7
Badge +14

Hi @MiryLopez 

Try this tip:


Userlevel 1

Thanks for the suggestion. I opened a new private browser and follow the steps to connect Salesforce. The only change was that once I clcked on allow it took me to my connected apps and I did not see the option to reconnect, so I thought it worked, but then I try to create a new zap and when I selected the salesforce account it is giving me the same error message. 


Userlevel 7
Badge +14


Help articles for using Salesforce in Zaps that may provide guidance:

Userlevel 7
Badge +6

Hi @MiryLopez,

Welcome to the Community! 🎉

It looks like you’ve reached out to our Support Team about this and they replied on Saturday with a suggestion. I’ll share details of the suggestion here in case it’s helpful:

Thank you for your patience! I am sorry for the delayed response. We currently have a high volume of requests and are working to reply as quickly as possible.
Looks like you didn't receive my colleague's previous response. Just in case, I am sending it once more to see if it works. This is what he wrote:

Hi there,
Thanks for getting in touch. This is Kristopher from Zapier Support. Happy to help!
From what you've mentioned, it seems like your Salesforce sandbox connection is expiring shortly after you successfully connect it. This usually happens when there are issues with API access or when the security settings in Salesforce are not configured to allow Zapier to maintain a stable connection.
To help resolve this, could you please try the following steps:
1. Verify that your Salesforce account has API access. The Salesforce sandbox account must have API enabled to work with Zapier.
2. Check your Salesforce security settings. Ensure that you've allowed Zapier to access your Salesforce data. This can be done in the "Connected Apps OAuth Usage" section in Salesforce.
3. Reconnect your Salesforce account to Zapier. Once you've checked the above points, try reconnecting your Salesforce account to Zapier and observe if the issue persists.
To reconnect your account, go to the My Apps page and click the "Reconnect" button:
Learn more about managing your Zapier connections here:
Please let me know how it goes after trying these steps. Your feedback will be valuable in helping us to identify the issue and provide appropriate solutions.
Thank you for your cooperation! Looking forward to your reply.
Kind Regards,

Please give this a shot and let me know how this works for you. Happy to help.
Kindest regards,

If you’ve got any questions regarding their suggestion it would be best to continue the conversation with them over email. If you can’t locate their reply I’d recommend searching your spam/junk folder or searching your inbox for any emails from in case. Sometimes their emails can end up in the spam/junk folder by accident.