Gravity Forms attachment URL showing \/ resulting in textfile upload

  • 22 April 2023
  • 3 replies

Userlevel 1

I am trying to send a Gravity Form attachment (company logo) to Airtable using Zapier. I have done this in the past and always worked like a charm.


Now, the trigger Form Submissions in Gravity Forms shows a file url similar to this: 


Can anyone explain why the url has the added backward slashes \\ ?


I tried adding a step uploading the file to Google Drive, but this results in a txt file being created with the faulty url as its contents. 


Your help is appreciated!

3 replies

Userlevel 3
Badge +4

Hi @JortArie 

Thanks for reaching out to the Community!

Before we dig deeper into this, could you send screenshots of how you’ve configured the steps of the Zap so far? Please include the part where it shows the faulty URL. That’ll help me make sure I give you the best suggestion possible.

(If there’s any personal information, kindly blur them.)

Looking forward to your response!

Userlevel 1

Hi @Charie, of course!







Userlevel 7
Badge +14

Hi @JortArie 

Good question.

Few things to point out.

  1. The URL is escaped for special characters which is why the \ comes before the /
  2. You’ll need to handle removing the “ at the start and end
  3. You’ll need to handle removing the [ ] at the start and end


Looks like there can be multiple URLs as well which would require using the Looping app to handle each individually.


You can use a Code step in the Zap to do all this instead of multiple Formatter steps.

Or you can use an AI step (OpenAI or ChatGPT).


If you need help configuring the Zap, consider hiring a Certified Zapier Expert: