Best answer

Duplicate messages in Trello from Slack for user research requests

  • 14 September 2023
  • 7 replies


Hi there


Our  User Research team use a Zap to get research requests from the Slack workflow on our user research requests Slack channel to the inbox of our user research projects board in Trello. The problem they are having is as well as the original request (message), every reply also gets pulled through to the board.

Can anyone help?


Best answer by ken.a 15 September 2023, 08:14

View original

7 replies

Userlevel 7
Badge +6

Hi there @FreeAgent,

Welcome to the Community! 🎉

Before we dig deeper into this, would you mind sharing a detailed screenshot of how your Zap is configured? Also, a screenshot that shows the “Action” section of your action steps? Here’s an example screenshot:

(view larger)

Please don't include personal information in the screenshot, or be sure blur out any personal information.

Thanks! 😊

Hey @ken.a 

Thanks. See attached

Userlevel 7
Badge +6

Hi there @FreeAgent,

Thanks for the screenshot!

I did some digging into this, and it seems like the “New Message Posted to Channel” triggers on replies on the thread. We do have an open feature request to differentiate between parent/thread messages in the “New Message Posted to Channel” trigger. 

I have added you as another interested member to the feature request. That does a few things:

  • Bring this to the attention of the integration developers
  • Help track interest in this feature being implemented
  • Allows us to notify you via email if this feature becomes available in the future

While I don't have an ETA on when this feature might be implemented, we will notify you via email if it is!

In the meantime, there’s a workaround I’d like you to try, by adding a Filter by Zapier step after the trigger and setting up the filter like this:

(view larger)

Please let me know if the workaround worked. 😊

Hey @ken.a 

Thanks so much for the reply and the suggested workaround. I don’t see filter setup and testing in our Zapier account. I winder if that’s not on out plan :( 

Userlevel 7
Badge +6

Hi @FreeAgent,

You can search for Filter by Zapier by following this GIF:

(view larger)

Hopefully, this helps! 😊

Hi. I just want to add that I’m having the same issue - Every time someone posts a comment in a thread for an existing post, where the original post meets my “continue only if” condition, the zap is triggered again, and passes the new comment of the thread through to the next step in my zap (even though the “continue only if” condition is specific to the text from a specific line in the original text of the post).

This has been a problem for a long time already.  Yesterday I tried changing my zap to only check for the trigger words in a specific line of the original post (using the “split response to line items” option) - it’s a post from a bot, with a predefined template, so I know which line to check for the trigger words.  I thought that would inherently prevent zapier from being triggered by thread comments, but no such luck. 

Note - I see that there’s now a Boolean filter option for “Is Thread”, but that one seems to be True if there exist any thread messages (i.e. making it a thread) and not as I expected a check on whether the message itself is a thread message (or a parent post) - ie. looks like it’s just a nicer wording for your above suggested workaround of checking whether a Ts entry exists.

Since our bot automatically always automatically adds an initial comment to the thread of each post (with a zendesk issue link), every post I’m tracking will always come back as true for “Is Thread”.  

What I’m looking for is a filter option to say IsParentPost true/false - so that it will only continue if the post is a new (parent) post & not be triggered each time comments are added to the thread (but that the existence of comments in the thread shouldn’t prevent the parent post from successfully passing the test condition). 

I’d love to know the ETA for fixing this issue?   Let me know if you need any additional specific details about my case, but seems like the problem is the identical cause as described above.

Userlevel 7
Badge +6

Hi @JackieDoc,

I have replied regarding your question to this post that you created: 

Hoping to hear from you on that post soon!