Question

Webhook with multiple objects changing fields

  • 31 August 2022
  • 1 reply
  • 240 views

I am a Salesforce user that updates records in bulk frequently. 

When I update records to a certain criteria, it calls a Zapier webhook.

Here is my problem, the Zap works fine for a single webhook call with a single object. Example:

 

When I run a bulk operation in Salesforce it calls the webhook and sends multiple objects in one API call and it then breaks the Zap:

 

I have tried to run a Loop step which seems to work fine with multiple objects but then it fails when there is only a single object:

Here is the error on a single object call:

Despite the API having the same name, it doesn’t work for both multiple object and single object use cases:

 

What is the best way to solve for this?


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +14

Hi @pjmitch8 

Good question.

Try this…

Use 2 Webhooks with 2 Zaps. (see section below for triggering multiple webhooks from 1 request)

Add a Filter as Step 2 to each Zap.

  • 1 Zap to handle the single results
  • 1 Zap to handle the multiple results

 

6. Optional: Trigger multiple Zaps with webhooks

 

If you have multiple webhooks you want to trigger from the same event in your app, you can combine their URLs into a single URL.
For example, if you have three Zaps, the URLs would look like this:

https://hooks.zapier.com/hooks/catch/123456/zbB61

https://hooks.zapier.com/hooks/catch/123456/kzXC4

https://hooks.zapier.com/hooks/catch/123456/2Ajjn

You can take the last part of each URLs and combine them into a single URL like this:
https://zapier.com/hooks/catch/123456/zbB61,kzXC4,2Ajjn

Requests sent to this URL will trigger all three webhook URLs at once.