How can I generate a longer blog post using ChatGPT in Zapier?

  • 12 February 2024
  • 1 reply

How can I create a long blog post in zapier? I put max tokens 4096 but it generates 1000 max. I suspect it can be done in parts?! what is the mode of chatgpt that display more tokens? model:gpt-4-0125-preview

1 reply

Userlevel 7
Badge +11

Hello and welcome to the Community, @NAM! 👋

I’ve seen similar reports of this where there was a long conversation history that resulted in less tokens being available to use when Zaps were run. But for those cases there was a error message to say that the maximum token amount was exceeded. To solve that a unique Memory Key was set which helped to get around that issue by resetting the total of tokens available as it started a new conversation under a different memory key. Did you see any such error or is it that it’s running successfully but is always using only 1000 tokens?

Also, can I just double-check as you said that you wanted it to “display more tokens” - when you say tokens here are you in fact referring to words that it’s outputting? If so, is the issue that it’s cutting off the generated blog content before it’s completed the blog post. If this is occurring during testing in the Zap editor then that would be the expected behaviour as the processing time is limited to 50 seconds so it will only return what was generated during that time. But when the Zap is switched on and runs live, it’s allowed up to 15 minutes to process the request so it should return the full blog post.

Could that be the case here? If not can you please send over a screenshot showing what fields and settings have been selected in the Action section of that ChatGPT action? I’d like to take a look at that to see if there’s anything on the setup there that might be preventing the Zap from using the correct number of tokens. Please remove/hide any private information (like names, emails, addresses etc.) from any screenshots before sharing.

Looking forward to hearing from you on this!