Best answer

Zap keeps halting due to duplicate tweets

  • 11 November 2021
  • 6 replies
  • 366 views

I have a zap set up to post a tweet to twitter when there is a post in a specified discord channel. The messages are not the same though the zap is being halted citing duplicate tweets. Any insite?

icon

Best answer by jesse 1 June 2022, 01:07

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +12

Hi @Bacon 

Could I get you to post some screenshots of your Zap setup?

Userlevel 7
Badge +14

Hi @Bacon 

Twitter error: “The tweet could not be sent to Twitter.”

Last updated: April 01, 2021

Symptoms

You may see this error message "The tweet could not be sent to Twitter" when using the Create Tweet action.

Causes

This error occurs if duplicate tweets are being created by your Zap, something that isn't allowed by Twitter's automation policies.

How to fix it

  • Go to the Create Tweet action in your Zap.
  • Edit the Message field to ensure the data mapped can create unique tweets each time the Zap runs.

 

I get an error "Unable to create tweet, duplicate of existing tweet detected" when using the Create Tweet or Create Image Tweet actions

Before posting updates to Twitter, a Zap will first check that the same post hasn't been made by any Zaps under the same Zapier user's account. The error message means that the same status was posted by either the same Zap or another Zap. Twitter has strict policies on automation and the use of multiple accounts as detailed in this post

Here are the screen shots of the zap .

Discord to twitter 

When post in discord channel 

Tweet sent with Gamer Malfunction presents:the content of the post, twitch link and the person who made the discord post 

 

@Troy Tessalone thank you I had checked that first and have the unique identifiers from the discord channel that change with each post to the discord channel. The tweets that are being sent causing it to be halted have not been posted in duplicate nor have they been posted before 

Userlevel 7
Badge +14

@Bacon 

You can try opening a ticket with Zapier Support for them to further investigate: https://zapier.com/app/get-help

Userlevel 7
Badge +9

Hey everyone! Just circling back here to close the loop with some advice from our support team, should anyone be running into similar issues:

Before posting updates to Twitter, a Zap will first check that the same post hasn't been made by any Zaps under the same Zapier user's account. The error message means that the same status was posted by either the same Zap or another Zap. Twitter has strict policies on automation and the use of multiple accounts as detailed in this post.
 
You might need to add original text or characters to each message to avoid the error.
 
You can find more information about common problems with Twitter here:
 
Common Problems with Twitter
 
Because of the above, it's currently not possible to post tweets with the exact same content. Feel free to reach out to Twitter directly for more information:
 
https://help.twitter.com/en/forms