Zaps using PostGreSQL don't trigger in Zapier but trigger on my Database

  • 14 May 2024
  • 1 reply

Hello everyone, 

We are facing an issue since several month. When we use a sql query as a trigger for a zap, sometimes it d’ont trigger, even if we have new queries in our database. We provide you one example, as you can see on the first screenshot : the zap didn’t trigger since several weeks. But as you can see on the second screenshot, on our database, the query triggered several times. It’s just an example for one zap, but it concerns a lot of our zaps. The zap worked at the beginning.

As you can see on the third screen, when we test the zap, it finds all the queries. So, the zap works if we engage it by hand, but we want to automate, we don’t want to lose time,.

We suspect that there may be an aspect of the query construction that we haven't fully grasped, preventing each new line appearing in the query's output from triggering the zap.

Would appreciate any help, because it’s very complicated to work with this situation.

Precisions :

  • We have already tried to reconnect PostgreSQL in Zapier 
  • We have already tried to turn off then turn on the Zap
  • Even if the zap is published (and not draft) it doesn’t work
  • We have already tried to contact Zapier assistance. They recommended to us to ask for a consultant’s help → it’s too expensive for us


1 reply

Userlevel 7
Badge +11

Hi @Hemea! 👋

That looks like quite a complex query and I’m not entirely unsure which part might be causing the issue here. I wonder if it might be worth attempting to simplify the query to see if that then allows the Zap to trigger?  

For example try with something like this: 
SELECT *, CONCAT(user_id, created_at) AS id FROM my_table ORDER BY created_at DESC

^ Replacing the ID column and table name to match your set up.

Then see if that is able to trigger the Zap. If it does, then I’d suggest further adding to the query and re-testing each time to help isolate what part of the query is causing the issue. 

And if it doesn’t trigger at all it’s likely that there’s a bug with the New Row (Custom Query) trigger for PostgreSQL. In which case I’d suggest reaching back out to the Support team to have that potential bug investigate further. 

Please keep us in the loop on how you get on with this, keen to help get this sorted!