Question

Zap (New File Trigger: Google Drive Folder > Create Row in Google Sheet) says it is working, but no data is populating the spreadsheet, at the top nor the bottom.

  • 29 April 2024
  • 2 replies
  • 13 views

Can’t seem to find a solution for this online. I have seen people with similar issues, but this seemingly simple zap just will not seem to work.

Notes:

  • Shared Drive but I am the owner
  • All Folders and Files are in this drive in which I am the owner
  • It’s a two-step zap, and the history says it’s working. I can confirm this by rerunning the zap which previously said “2 files added” which now says “searching for newnew” and ends there.
  • Spreadsheet is unformatted, no headers, no nada. 1000 rows, and checked the end, nothing there either.
  • Zapier Noob 

2 replies

Userlevel 7
Badge +11

Hi @DJ-Nerfherder, welcome to the Community! 👋

If it’s triggering ok but new rows aren’t being added to the spreadsheet then there might be an issue with the setup of the Google Sheets spreadsheet or action. Please see our Work with Google Sheets in Zaps guide to double-check that the setup of the spreadsheet is correct. You mentioned that the spreadsheet has no headers so that may potentially be the issue here.

But I’d also recommend checking the Additional Tips section of that guide to ensure none of the changes mentioned there were carried out in the spreadsheet. If they had, can you turn the Zap off and back on again to see if that then gets it adding new rows to the spreadsheet as expected?

If the above doesn’t sort it, can you please share a screenshot of any errors you might be seeing in the Zap History, and a screenshot showing the set up of the Google Sheets action in the Zap. That will be super helpful to us in identifying what’s causing the breakdown here. Please remove/hide any private information (like names, emails, addresses etc.) from any screenshots before sharing.

Looking forward to hearing from you on this!

Userlevel 6
Badge +6

Hey @DJ-Nerfherder ,

 

Can you share the screenshot of how did you configure the Action 2 of the Zap? Also can you share a screenshot of your google sheet? 

Reply