Question

{{zap_meta_human_now}} defaulting to GMT


Userlevel 2
Badge +2

Hello,

I have my Zapier account configured to America/Los Angeles.

I have some date-time fields in Airtable which Zapier writes to.

I usually use the {{zap_meta_human_now}} value and the times display correctly in Airtable (where the fields are configured to display local time).  To be precise, the time displays correctly across user timezones, and is correct to the hour throughout the year whether in daylight savings time or standard time.

Since 6/30/2022 the records I have such configurations writing to have been getting their time values set to what looks like GMT hours.

Switching the Zapier time setting to {{zap_meta_pst_iso}} gets me in the ballpark, but now if I need correct to the hour timestamps, I will have to update all my zaps every six months for daylight saving.

What happened that cause {{zap_meta_human_now}} to stop behaving?

Thanks!


14 replies

Userlevel 7
Badge +9

Hey there, @mixelpix! Huh, that is odd!

Do you mind checking the Account Time Zone in your Zapier account settings for me?

https://zapier.com/app/settings/profile

The default is UTC/GMT so I’m wondering if somehow that was switched up. Keep us posted! We definitely want to get to the bottom of this with ya.

Userlevel 2
Badge +2

Hi @christina.d,

The Account Timezone is set to:

GMT-07:00 America/Los Angeles

...also an example Zap history (from when zap meta human now was used) shows, “This Zap run used the America/Los_Angeles timezone” with a reported field value of “07/28/22 02:53PM"

...and the database has “7/28/2022 8:53am” on the record (with no changes to the field since it was written) 🤷‍♂️

Userlevel 7
Badge +12

@mixelpix 

Can you double check the field settings in your Airtable account? Be sure that it is set to use local time and that “Use the same time zone...” is not checked

 

Userlevel 2
Badge +2

Can you double check the field settings in your Airtable account? Be sure that it is set to use local time and that “Use the same time zone...” is not checked

 

Thanks for the suggestion, but that is not the problem.  The Airtable structured datetime field is set to display local time (not GMT) and the date format set to "Local” e.g. 7/28/2022 8:53am

Userlevel 7
Badge +12

Hi @mixelpix!

Thanks for bearing with us and checking timezone settings in your account and in Airtable. I haven’t heard that the {{zap_meta_human_now}} field has changed, so we need to rule out all of the other options first. There’s one last place that you can check in Zapier - the Zap’s timezone. In the Zap settings, you can set a timezone specific to that Zap.

By default this is set to the timezone from your account settings, but you can change the timezone of Zaps individually if/when you need to. 

 

If the timezone in the Zap settings looks correct, the next thing to do is to contact the Support Team (using the Get Help form). The Support Team can take a metaphorical microscope to the Zap’s logs and can see at what point the timezone was incorrect (ie when it was generated, when it was sent to Airtable, when it was received by Airtable, etc). I recommend sending a link to this post so they can see what steps you’ve already taken to try and solve this one. 

 

Let us know how it goes 😊

Userlevel 7
Badge +14

@mixelpix 

Check your Zap Runs to see the timestamp value in the DATA OUT step that was sent to Airtable which may help you troubleshoot whether the issue is with the Zap step or with Airtable Date field settings.

Userlevel 2
Badge +2

Hi @Danvers and @Troy Tessalone did either of you read the original post?  Your questions are all addressed there.  Thanks tho.

Userlevel 7
Badge +14

@mixelpix 

Screenshots with how your Zap steps are configured and how your Airtable Date fields are configured are the best way to provide context and proof for us to review, along with outlining a specific example to trace the data flow, thanks.

Userlevel 7
Badge +12

Hi @mixelpix, I’m sorry if I misunderstood your earlier posts. 

I asked about the Zap timezone setting as you can set it independently from your Zapier account timezone settings (ie your account can be in Pacific but your Zap in GMT). I can see that you included details from the Zap run showing the timezone settings, I’m sorry I missed that clue. 

...also an example Zap history (from when zap meta human now was used) shows, “This Zap run used the America/Los_Angeles timezone” with a reported field value of “07/28/22 02:53PM"

...and the database has “7/28/2022 8:53am” on the record (with no changes to the field since it was written)

 

The reason that Troy suggested looking at the data out in your Zap run is because if you check the data in and out for each step in a Zap run, it can give sometimes lead you to the source of the issue. For example, if the Data Out of the step with {{zap_meta_human_now}} in it has the pacific time, and the data in for the Airtable step has Pacific time, but the Data Out for the Airtable step has GMT, then we know that something has happened between Airtable receiving the data and it adding the data to the table. 

 

It sounds like you’ve already done a lot of checking and digging and I think it’s worth contact the Support team on this one. They can check the logs for the Zap to see exactly what was sent to Airtable and what Airtable returned. I’m sorry that we weren’t able to get to the bottom of this in the community!

 

 

Userlevel 2
Badge +2

thanks

Userlevel 7
Badge +9

Hey there, @mixelpix!

Don’t mean to be a bother - I just noticed a ticket hadn’t been opened and was wondering if you were able to get to the bottom of this on your own? 

Keep us posted. 🙂

Userlevel 2
Badge +2

Hi @christina.d

 

I haven’t opened up a ticket, nor figured out the cause.  It’s definitely curious, but not enough of a show stopper to warrant further pursuit.  Thanks for checking back :) 

Userlevel 1

I found this thread when I was setting up a new Zap and the tests were coming in with zap_meta_human_now in GMT so I thought I was having the same issue as OP. Turns out for me that it’s only tests that are broken and the actual Zap runs are working ok, but this is still annoying and should be fixed.

Userlevel 2
Badge +2

hi @hcs - thanks, that’s helpful context for future readers!  And likewise, I’ve experienced the same behavior you describe when initially testing.

Reply