Question

{{zap_meta_human_now}} defaulting to GMT

  • 5 August 2022
  • 4 replies
  • 27 views

Userlevel 2
Badge

Hello,

I have my Zapier account configured to America/Los Angeles.

I have some date-time fields in Airtable which Zapier writes to.

I usually use the {{zap_meta_human_now}} value and the times display correctly in Airtable (where the fields are configured to display local time).  To be precise, the time displays correctly across user timezones, and is correct to the hour throughout the year whether in daylight savings time or standard time.

Since 6/30/2022 the records I have such configurations writing to have been getting their time values set to what looks like GMT hours.

Switching the Zapier time setting to {{zap_meta_pst_iso}} gets me in the ballpark, but now if I need correct to the hour timestamps, I will have to update all my zaps every six months for daylight saving.

What happened that cause {{zap_meta_human_now}} to stop behaving?

Thanks!


4 replies

Userlevel 7
Badge +8

Hey there, @mixelpix! Huh, that is odd!

Do you mind checking the Account Time Zone in your Zapier account settings for me?

https://zapier.com/app/settings/profile

The default is UTC/GMT so I’m wondering if somehow that was switched up. Keep us posted! We definitely want to get to the bottom of this with ya.

Userlevel 2
Badge

Hi @christina.d,

The Account Timezone is set to:

GMT-07:00 America/Los Angeles

...also an example Zap history (from when zap meta human now was used) shows, “This Zap run used the America/Los_Angeles timezone” with a reported field value of “07/28/22 02:53PM"

...and the database has “7/28/2022 8:53am” on the record (with no changes to the field since it was written) 🤷‍♂️

Userlevel 7
Badge +11

@mixelpix 

Can you double check the field settings in your Airtable account? Be sure that it is set to use local time and that “Use the same time zone...” is not checked

 

Userlevel 2
Badge

Can you double check the field settings in your Airtable account? Be sure that it is set to use local time and that “Use the same time zone...” is not checked

 

Thanks for the suggestion, but that is not the problem.  The Airtable structured datetime field is set to display local time (not GMT) and the date format set to "Local” e.g. 7/28/2022 8:53am

Reply