Best answer

Zap History shows Null Data - Filter Step - Even though Data Out is Present

Userlevel 1

I am connecting MyCase to Google Drive, with MyCase being the Trigger. The specific trigger is: Case Updated based on Case Stage. When I run test data inside of the Editor, it pulls information properly based on the work I do in MyCase.

Each stage has a Case Stage Reference ID and I want to run certain actions based on a specific stage. Therefore I filter using Text Exactly Matches...the known Case Stage Reference ID which in this case is 597269

Everything works in the Editor….HOWEVER...when I Publish, the Zap stops because null data is coming through, as shown below on the Data In Tab. Interestingly on the the Data Out Tab (second image)...

Null Text Error.

...the very data I want is there….


It is getting the data and the proper Case Reference ID

Am I losing my mind, or is this not working as it should? Please help.


Best answer by Pocket Office 21 May 2024, 21:37

View original

6 replies

Userlevel 7
Badge +14

@Pocket Office 

Sorry follow this help article doing custom pill mapping:


Userlevel 1

Okay so I’m just putting this here for posterity. Thank you Troy for guiding me to the answer. 

The ERROR was: The Editor and the Run Environment did not coincide.

The SOLUTION PATH involved answering the following questions:

  1. How do I gain access to a variable that Zapier doesn’t turn into a line item?
  2. How do I use that in a variable in my Filter step?


  1. Use Custom Pill Mapping - DIY Tutorial: How to Create Custom Pill Mapping in Zapier. Thanks again Troy.
  2. Use the Text in Formatter by Zapier > Event: Text > Default Value. For the input, I put my custom pill, which turned out to be {{240127961__case_stage_reference}}. I picked of the air a default value of 000, then I used that Output Value in my Filter.

Problem solved by Troy.

Userlevel 7
Badge +14

Hi @Pocket Office 

Can you post screenshots with how your Zap Filter step is configured in EDIT mode?

Userlevel 1

Certainly! Here you are.

These are the values being read from the first step.
This is the logic of it.

Now let it be know, I’ve tried using CONTAINS as well. No results with that either.

Userlevel 7
Badge +14

@Pocket Office 

Here’s the issue…

The DATA OUT from live Zap Runs is: case_stage_reference

But the DATA OUT from the Zap editor config is likely: case_stage_reference_id

Those are treated as different variables.

Not ideal, but can be a quirky with how some Zap app developers configure their Zap app integration on the Zapier Developer Platform.




Try using a named variable, that you first enter into this Zap action: Formatter > Text > Default Value

Then map the Formatter output variable to the Filter step condition left side.


Userlevel 1

(And thank you so kindly for responding) Pardon me please, it seems I may need a bit of handholding because the only data that I can manipulate from within the Editor is Case Stage Reference ID.

How would I go about creating a named variable when the only entry I can Split or use the Default value of, is Case Stage Reference ID. Additionally I can’t control the format of the MyCase polled data. So I can’t make named variable as suggested in the link you highlighted.

I see the value, but I don’t have access to that. Zapier only sees it as a structure, not a variable.

So I’m lost as to what to put in these fields below. When I put the ID..I get an error. Because it’s technically null.

I just don’t have access to the case_reference_stage.

I’m sorry if I seem dense.