Trouble getting a Wufoo form to upload submitted images into a Dropbox folder

  • 6 February 2024
  • 7 replies


I am trying to set up a zap to have images submitted on a Wufoo form upload to a specific folder in Dropbox and can not figure it out.

I have tried the suggested zap that I found online. 

Trigger: New Entry (Wufoo) 

Action:  Upload File (Dropbox)


However, every time I do this I get an error when I test the step. 

Failed to create a file in Dropbox

The app returned "Not Found".


At first I thought maybe I was not selecting the right file from my Wufoo form options. But I tried every one possible and still I get an error. 


I read somewhere that Dropbox won’t allow an upload file action if it is coming from a site that requires a password (in this case Wufoo)? I am not sure if this is causing the issue? If so, is there a way to get around that?  


Seems like it should be an easy one to do, but I just cannot get it to work. Any help would be greatly appreciated. I can provide more details if needed. 



7 replies

Userlevel 7
Badge +14

Hi @ReaceK 

For us to have full context, post screenshots with how your Zap steps are outlined and configured, thanks.

Hi @Troy Tessalone,

Here are screenshots for the Dropbox portion. For the Wufoo part, I just have the form selected I am trying to get images from. When I test the first part, everything is ok. It is the dropbox portion that is giving me trouble. 

Let me know if you need any other specific screenshots. 


Userlevel 7
Badge +14


Screenshots didn’t upload.

@Troy Tessalone 

Sorry about that. Here they are. 


Userlevel 7
Badge +14


Try refreshing your Zap trigger examples and selecting a more recent example to use to test you Zap action steps.

The mapped variable for the File field is a temp file that expires after a short time.


@Troy Tessalone 

I tried refreshing the example and selecting a similar field (one that says Exist but not shown) and I still get the error. I then tried selecting a field that contained a URL for the image and the test goes through, but I get a .txt file uploaded to my dropbox and not the image itself. Below is screenshot of the URL field I selected. 


Userlevel 7
Badge +14


This looks like multiple files names.

The File field expects file objects or files urls.

Resource to reference for help sending files in Zaps;


If there can be 1+ then you can use the Looping app: