Best answer

Problem with Quickbooks Online Create Bill Action with foreign currency

  • 1 September 2022
  • 15 replies
  • 243 views

Userlevel 1
Badge

I’m automating for a vendor who sends invoices in GBP.

I have multicurrency setup in Quickbooks Online. 

When I set up the action and try to test it, I get an error “The currency and exchange rate are required for transaction in foreign currency.”

But the dropdown option in the setup area only provides a currency types eg. GBP, USD etc and there is no other field for Currency Rate.

Am I supposed to enter a custom string for Currency that includes the rate?  like ‘GBP 1.123’ ?? I tried that and it failed.

 

icon

Best answer by bobbyk 2 September 2022, 19:17

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

15 replies

Userlevel 1
Badge

so… Zapier Support just confirmed its a Zap bug. So now it’s in the developer queue. I’ll post back here if/when it gets resolved.

 

“Hi Robert,
 
It appears that this is a bug with the QuickBooks integration. Essentially, there needs to be an Exchange Rate field in the Create Invoice action so that it can be set when there is a different currency selected. It seems that QuickBook sets this to 1:1, and that would mean you would need to edit the invoice each time the Zap is run if you use that field. Since this isn't an option in the Zap, I've gone ahead and added you as an affected user to that bug report.”

 

 

Userlevel 1
Badge

Hi 2 months on… any updates on this? the bug seems relatively light weight in that its just adding one field to fix the issue? its a showstopper for Foreign invoice automation right now!

Userlevel 7
Badge +9

Hey there, @bobbyk - I’m sorry to say no updates on this one at the moment. 😞

I know that’s disappointing but rest assured once a fix ships we’ll email you and post here in community as well! Thanks again for sharing your feedback and checking in with us.

**Scratch that I think I found a fix**

Any update on this? I am also an impacted user. It would help if I get an email if this bug is fixed. Thanks!

@christina.d 

Userlevel 7
Badge +9

Hey there, @Kushank Aggarwal - sorry to hear you’re running into this too.

While I don’t have any updates I did add you as an impacted user. This is the best way to stay informed as you’ll be emailed once a fix is in place. 

Thanks for reaching out!

Userlevel 6
Badge +3

Hi @edwardlacs 

I’ve added you to the list of impacted user, and we’ll notify you via email once an update is available. Thanks!

Userlevel 7
Badge +9

Ah, I’m sorry to hear you’re being impacted by a bug. 😔 We’ll also continue to monitor on our end and keep the topic updated once a solution is in place!

Thanks so much for looping back around to update the Community on your findings, @bobbyk! It’s very much appreciated. 🙂

Userlevel 7
Badge +9

Hey there, @bobbyk! Oof, sorry to hear you’re running into this! 

Are you able to share screenshots of your zap setup (with any personal details removed) with us? Also are able to share a screenshot of the error and where you’re seeing it? I think those things may help us with troubleshooting with ya. 🙂

Thanks so much! 

Userlevel 7
Badge +9

Hey there @JeffBES - we appreciate you sharing your feedback with us. I know this is frustrating, and we definitely hear you.

While I still don’t have an ETA for a fix, I assure you we’ll share any updates here in the thread and email anyone who’s reached out to us advising they’re impacted. For context, prioritization of bugs is largely dependent on the number of customers affected, the complexity of the bug, how many users have reported it, and the scope of fixing it. Since we work with over 5,000 applications it’s tough to offer estimates or timelines when a fix will be ready.

While I imagine that’s not the answer you were looking for, I hope the context helps. Thank you again for taking the time to reach out.

I understand, but this missing exchange rate field is blocking a lot of automations for my business and I have to start to look into parallel automations solutions. Thanks for the reply.

I’m automating for a vendor who sends invoices in GBP.

I have multicurrency setup in Quickbooks Online. 

When I set up the action and try to test it, I get an error “The currency and exchange rate are required for transaction in foreign currency.”

But the dropdown option in the setup area only provides a currency types eg. GBP, USD etc and there is no other field for Currency Rate.

Am I supposed to enter a custom string for Currency that includes the rate?  like ‘GBP 1.123’ ?? I tried that and it failed.

 

I contacted Zapier maybe 2 years ago about this problem that force us to import manually vendors invoice because we have a multy-currency vendors and clients business (welcome to the business world) and nothing have been done. JUST NEED AN EXCHANGE FIELD! that must be so hard to implement… if I can do it with a CSV it can be done wuth a ZAP.

Userlevel 1
Badge

Hi @christina.d,

 

Happy to clarify! I’ve included 3 shots. The first is a full view of the QBO Action Setup. The second is the Test summary and the 3rd is the error reported. As you see its expecting that I provide the Currency Rate, however there only seems to be a field for Currency Type, which I have set to GBP, as my vendor invoices me in GBP and is setup in GBP currency in my QBO account.

I am having the same issue, any updates @christina.d ?

Any update on this? 

It is extremely annoying.