Question

Looping with incorrect formatting

  • 14 January 2024
  • 4 replies
  • 36 views

We are experiencing an issue with the Looping step in our Zap.
We are using a formatting step to separate by line item, but when we select it in the loop stage, it’s coming in as comma delineated.

Here’s a video showing the zap and the issue: https://drive.google.com/file/d/1gJVlsVdVArtaJU1CDj7JeAFbQIVvhO0x/view?usp=sharing

Any help or advice is much appreciated.


4 replies

Userlevel 7
Badge +14

@sethferguson 

Also, check your Zap Runs to see the DATA IN/OUT for each step to help you troubleshoot: https://zapier.com/app/history/

Userlevel 7
Badge +14

@sethferguson 

We would need to see screenshots with how your GSheet Zap step is configured with the variables mapped from the Looping step.

Looping help: https://zapier.com/apps/looping/help

 

You may want to try using Loom.com for the videos.

 

Hey @Troy Tessalone,

Appreciate the tip!

However, we’re getting data in 1 of the spreadsheet cells, but it’s missing the other cells.

Quick video: https://drive.google.com/file/d/1GIS7E2RPzNxMqW9x8VeEWB6aFHBtsteT/view?usp=sharing

Userlevel 7
Badge +14

Hi @sethferguson 

You may not need the Formatter steps.

The Formatter Input you have selected is an array of items.

By using the Formatter it’s creating an array of arrays. (see the 1 followed by the 1, 2, 3...)

That causes the GSheet step to not work as expected.

The Zap action for Looping Create Loop from Items already handles line items. (aka arrays).

 

Reply