Question

"invalid_request_error" Google Drive to Whisper Transcription

  • 14 May 2024
  • 3 replies
  • 11 views

Hi!

I am trying to send an m4a file from Google Drice to OpenAI for getting its transcription and I get “Failed to create a transcription in OpenAI (GPT-3, DALL-E, Whisper) The app returned "invalid_request_error".” 

I also tried to use another file, or even One Drive instead and the result is the same: "invalid_request_error". 

I attach the screenshots, hope it will help to detect the problem.

My Google and Openai accounts connect properly and I have a payment method and API key connected.

 

 

 

 

Thanks in advance for your help!


3 replies

Userlevel 7
Badge +11

Hi @Pazzerifero 👋

It’s been a while since you posted here so not sure if you’ve already solved this? I can see that you also reached out to our Support team about this and they identified the cause of these errors, but I couldn’t see any reply from you in that email thread so I’m not certain whether you saw their response. I’ll share their findings on the cause of the error here in case it’s useful to you or anyone else that’s running into a similar error with OpenAI: 
 

Based on the error, we're seeing this because of the file format. This is what I found in the logs: 

"Invalid file format. Supported formats: ['flac', 'm4a', 'mp3', 'mp4', 'mpeg', 'mpga', 'oga', 'ogg', 'wav', 'webm']"

Please ensure any and all files uploaded are in this format to avoid any errors. 


Based on the additional error details the Support team found in the logs it appears that OpenAI was not recognising that m4a file as a valid m4a file. Was the file zipped at all perhaps? 

Keen to ensure you’re all set here so please do let me know whether you’re in need of any further assistance here! 🙂

Hi @fiona819

Thanks for your response! The file is 360kb so I don't think that's it unfortunately. 

Userlevel 3
Badge +3

Hi @Pazzerifero May I know how large is your file in google drive for transcription? There is a file size limit so wanted to check if that is the issue.

Reply