Best answer

Google Sheet error: Failed to create a spreadsheet row in Google Sheets. Unable to parse range: 'Sheet 1'!0:0"

  • 26 July 2022
  • 2 replies

Hello, I created a zap with the trigger : New deal in Hubspot, the action: Get Many Spreadsheet Rows to select a specific cell and a third zap : Update Spreadsheet Row in Google Sheets.The first two work very well but for the update, I have an error message that appears: "Failed to create a spreadsheet row in Google SheetsThere was an error writing to your Google sheet. Unable to parse range: 'Sheet 1'!0:0"(I checked that the ranges and the sheets were not protected and switched to "Editor" modeIf someone has an idea .Thanks,

Best answer by Troy Tessalone 26 July 2022, 16:15

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 2
Badge +3

Hi @CarolineLaval !

Just passing by to see if you were able to check what @Troy Tessalone sent, and if your Zap is now working as you expect it to?

Let us know if it’s still not quite right 🙂

Userlevel 7
Badge +14

Hi @CarolineLaval 

Good question.

I'm seeing an errors that mention 'range' (cannot parse range, requested writing within range)

If you are getting an error that says something like cannot parse range or 400 Error: Requested writing within range ['DO NOT EDIT: Feed via Zapier'!A74], but tried writing to column [B], there are a couple of possible causes:

  • There is a colon (:) in your worksheet or spreadsheet title. If so, try removing it - colons in spreadsheet and worksheet titles can sometimes cause a Zap to malfunction.
  • There are no fields mapped in the Zap. This error sometimes occurs when the Zap attempts to add a completely blank row.
  • The spreadsheet/worksheet name has changed. Make sure you turn the Zap off while you make the change, and then turn it back on again after.