Best answer

Google Form submission to New ticket in Zendesk - pulls the wrong Zendesk form

  • 11 October 2023
  • 3 replies

Userlevel 1

Hi all, 

I am trying to setup the following simple zap: 

Whenever there is a new submission on a specified Google Form to create a new ticket in Zendesk. 

Our company’s Zendesk plan is Enterprise and we have several different Groups for the different teams using it, as well as different ticket forms with each triggering unique fields on the ticket. 

The problem I run into is the following: 
Regardless of the fact that I have selected the correct Zendesk Support ticket form for my team, I get 76 required fields that I have to fill out on the Zap in order to make it run. 
To clarify - I don’t have 76 fields on the ticket form I am selecting 😅
I’m attaching a screenshot to visualize the issue. 

I have other 3 Zaps running with Zendesk and I haven’t encountered the problem there. 
My suspicion is that this happened because I was prompted to update the Zendesk connection on Zapier and that messed up something. 

Could the problem be with the Zendesk API? Maybe I should generate a new API key or something similar. 
I am not entirely sure how to go about this but it’s very frustrating.
And yes, I have tried setting up a different Zap using other apps like Slack to Zendesk, Sheets to Zendesk but I still run into the same problem. 

Thanks for reading and for your help!



Best answer by Dimana D 11 October 2023, 21:08

View original

3 replies

Userlevel 7
Badge +6

That’s great news @Dimana D! Glad to hear that the issue is now fixed!

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 🤗

Userlevel 1

Hi @Troy Tessalone  and thank you for replying! 
I did but that was the issue, I was seeing required fields that were not even present on my selected Zendesk form within Zendesk. 

Anyway, it seems that the issue has been fixed earlier today, because when I tested it again a few hours after I posted here, I was no longer seeing the “required” on all those fields anymore 😅
I have no idea what cased the issue but I’m glad its fixed. 

Userlevel 7
Badge +14

Hi @Dimana D 

Good question.

Only fields marked as required need to be populated in a Zap step.

Have you tried only populating the required fields and the fields that match your selected Zendesk Form?