Best answer

Google Docs error: The app returned "File not found: 1FA5jnpDX2_dlvbQ-1jds--T7oAwe9RI7HPCFCBKLhuw"

  • 28 October 2022
  • 13 replies
  • 1054 views

Userlevel 1

Objective: Upload a document to a folder in a shared team drive to use it’s info to progress to further zaps. 

Problem: The trigger is working and the documents successful loaded, but the zap says it is unsuccessful, not allowing me to use it’s information for my next intended zap. 

I understand there may be a current bug in identifying content in shared team drive based on the following posts



Is there a work around to this? Below are screenshot to the set-up, the results, and the Zap results. 

 

 

icon

Best answer by SamB 12 July 2023, 12:13

View original

13 replies

Userlevel 7
Badge +11

Hi @ZapinCompany

That’s super strange that the step does actually create the file but then throws an error. I tested this out myself with a Shared Drive and ran into the same problem. I tried turning the Zap on to see if it would run properly when live, but it hit the error.

I think your best bet here is to contact our Support team. I know Shared Drives aren’t officially supported, since you can’t select them in that Google Docs step, so they can either add your vote to any existing feature requests OR if it’s a bug they can file that as well.

Just want to add that this same issue is happening. If Shared Drives aren’t supported perhaps we can have an action to simply skip the error and allow final steps to be completed?

Userlevel 1

I encounter the same error. Zap works like intended, but the error is thrown. Meanwhile Zapier now always stops the rest of my workflow because of this. Until recently at least the zap would still run and I could happily ignore the error message. 

Now my Zap stops and doesn’t work anymore. 

 

There needs to be a workaround for this. 

Userlevel 1

I also run into this. The file gets crated correctly in the Shared Drive, but then an error so I cant publish it. And since I’m on the professional plan I cant ignore errors and is recommended to upgrade to company plan to be able to do that. But that is an annoying solution and to expensive solution for my zapier needs.

Any hopes for another solution to this? 

Userlevel 1

i also get the exact same error, even if i search the Document before and use the search result of that.

 

Userlevel 7
Badge +11

Hi @ZapinCompany, @patrickbreathen, @Parl Oa, @Emil H and @Beyond-Livin! 👋

I just came across this and it appears that you’re all being affected by a bug with the Google Docs app. You’ve all been added to the list of affected users which will help to increase the priority on a fix. I can’t make any promises as to when it will be sorted but we’ll be sure to send you all a notification by email as soon as it is. 

In the meantime, this error appears to be linked to the use of the Sharing Preference field and there’s a suggested workaround as follows:

  • Remove the selected value in the Sharing Preference field
  • After the Create Document from Template action, add a Add File Sharing Preference (Google Drive) action to set the sharing preferences for the document that was created. 


Not an ideal solution I know as it would mean an extra task is used each time the Zap is run but should hopefully help to keep things running until the bug is fixed. 🙂

I don’t think I’ve used the Sharing Preference field (I can’t find find), but I’m getting this issue. I have two other zaps that use similarly constructed Google Sheets, but only this one has that issue.

I’m just adding a comment to let you know that this issue is affecting me as well. I’ve tried this workaround, removing the sharing permission and it seems to have fixed the issue. But it is causing me to burn a couple of tasks to add additional steps to set permissions in a zap that runs frequently. This decreases my satisfaction and makes transitioning my automations to other providers a greater priority.

I’m not saying that part to be rude, but rather I know the logic “there’s a workaround so this is lower priority.” Just trying to help get fixing this prioritized!

 

Userlevel 7
Badge +11

Sorry to hear you’re both running into this same issue, @pod2go and @JasonBrett.

I totally agree that workaround isn’t ideal due to the extra tasks being incurred. I’ve added both of you to the list of affected users which does help to increase it’s priority, but I’m still unable to provide any sort of ETA on when it may be resolved by.

Really wish I had better news to share here. If we come across any better workarounds or have any updates on a fix we’ll be sure to share details of them here!

Userlevel 1

Hi everyone, joining this discussion as I seem to have a similar problem. These are my steps:

  1. I create a google docs with text (works fine) - I don’t have any sharing preference field there
  2. I add a Add File Sharing Preference field like suggested on this topic

 

  1. I try to get the same document that was created (and found in other steps) to append extra text to it, and I get this:

 

This is weird because the file can be found with a search step, and is created, but in this step it can’t be found. Do you have any other workarounds for this, because the sharing preferences one did not seem to fix my problem unfortunately.

 

Thanks in advance!

Adding a comment here to say that I am also being affected by this bug! The workaround also hasn’t helped in my case.

 

Interestingly, I have one path in my Zap where I’m having no issues copying my file into a newly created folder in Drive. In another path in the same Zap, I run into this error (same file, same logic in creating a new folder, just a different path for a different product). 

Really quite unfortunate that this hasn’t been resolved. When can we expect this to be resolved?

It’s also ridiculous that your product team isn’t studying the zap failures for situations like this and then addressing the bugs.

Userlevel 7
Badge +11

Hey folks 👋

@OptimAIze Labs and @startabroad8 - I’m very sorry we missed your messages here previously! @astrono - thank you for sharing your candid thoughts on how we could be better handing things. I’ve have passed your comments over to the Product team so they can take this into consideration and ensure we do better in future.

I’ve added you all to the list of folks being impacted by this issue. There is no ETA I can share on when it will be resolved by but we’ll be sure to let you know as soon as it is.

@OptimAIze Labs  - I’m not sure if you’ve already managed to solve this but I suspect the “File not found” error is being caused by what’s been selected in the Document Name field on the Append Text to Document action. My guess is that the name was selected from step 6 rather than the ID for it. Although that field is called “Document Name” when you use the Custom value option to select a value from a previous tigger or action step it will expect to receive the ID for the option (in this case the document) being selected. You can learn more about this here: Add custom values to dropdown menu fields in Zaps.

That said, I’ve just tested a Create Document from Template action and set sharing preferences and it worked without error. Here’s the set up I used:
5c73f4f37a0ddf7c4a248d1f33d110c5.png
And as you can see here no ““File not found” error appeared when I tested the action:
e7e60a3e0d17dcab187b2b6a8f0666bd.png
The file was created and the sharing preference added:
c9e10a68c58b5e4ae99a7cf7cdef7c93.png

So it looks as thought the bug regarding that “File not found” error appearing despite the action being successful, may have since been resolved although the bug report is still open. 🤔

For anyone that’s still experiencing a “File not found”error when using a Create Document from Template action and setting a sharing preference can you please share a screenshot showing the setup of the action? I’d like to take a closer look at the set up there to see if there might be an issue with the selected fields that might be causing the error. 

Thanks, I look forward to hearing from you all on this!  

Reply