Best answer

Failed to create a person or organization field value in Affinity: Please select a valid list entry

  • 30 March 2023
  • 9 replies

Userlevel 1



I’m trying to automatically add typeform responses to a list in Affinity. I can successfully pull the data from Typeform to create the entity in Affinity, fill in the mandatory global Affinity fields and add it to the desired list but when I try to update the fields in that list in the next step I keep getting an error (see below). I’m not sure why it can’t find the right entity in the list to update. I’ve tried using the Organisation name, the Organisation ID, the list ID and the entity ID (all taken from previous steps in the zap) but I get the same error about selecting a valid list entry. Any help would be really appreciated!




Best answer by Danvers 3 April 2023, 15:14

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

Userlevel 7
Badge +14

Hi @Churds 

Good question.

Please post detailed screenshots with how your Zap step is configured to give us context, thanks.

Userlevel 4
Badge +6

Hi @Churds 

Welcome to the Community! I'm sorry you’re having trouble with your Zap.

Can you please send screenshots of your Zap setup so we’ll know if there’s something wrong with the fields?

We’ll keep an eye out for your response.

Userlevel 1

Hey, thanks for the quick responses. Various screenshots below - let me know if you need any more.

First, the overall steps of the zap. Everything is working except step five.

I had tried skipping steps two and three and just automatically adding an organisation to the list but ran into some issues. I think this is because the list has one mandatory field that needs to be completed when a new org is added so using steps 2 and 3.

So step 2 adds the org to Affinity. Step 3 updates the mandatory field that’s needed before adding it to the specific list. Step 4 adds it to the pipeline list. Step 5 is then supposed to allow me to update the list specific fields for that org in the pipeline list.



Step five looks like this - I’ve cut off the 10s of fields that could be updated by the zap to save space. I’ve only filled in one text field so far as I just wanted to test if it worked at all but unfortunately no success.



This is where I’ve tried various different “list entry” options. In the screenshot you can see that I’ve chosen the organisation ID from step four when it was added to the target list.


Then when I run the test it gives me the error below.



Userlevel 4
Badge +6

Hi @Churds 

It seems like you’re on the right track. I want to know, what is your plan in Zapier?

Userlevel 1

Hey Brem,
I’m currently on the free plan - I’m aware this doesn’t allow multi-step zaps but I wanted to make sure the zap actually worked before upgrading.

Userlevel 7
Badge +12

Hi @Churds!

What do you see if you click on the dropdown list for List Entry? That will tell you what you need to use to tell that step which entity to update. 


In the example below, you would need to use the ID of the customer (eg if you wanted to update Brian Eno, you would use the ID 532).


If you look at the dropdown values for the List Entry field and you see a list of organizations with the organization ID, let us know (because you’ve tried that and got an error). 


​I hope that's clear, please let us know if you have any questions!

Userlevel 1

Hey Danvers - you’re my hero! I’ve got it working now 😁

Screenshots below for reference:

This is what List Entry showed.


So I needed to use the composite ID


Now it’s working exactly as planned!

Userlevel 7
Badge +6

Hey there @Churds,

Glad to know you were able to get it sorted with the help of my colleague Danvers! 🎉

If you have any other questions, please don’t hesitate to reach out. We are always happy to help! 😊

Userlevel 7
Badge +12

Woo! I’m glad that worked for you, @Churds :)