Best answer

Error 403 missing permissions Discord zap

  • 30 June 2022
  • 1 reply
  • 128 views

I’m suddenly getting an error when trying to troubleshoot my zap. It was working before, but suddenly is not working anymore. No changes were made to the zapier bot in Discord, or the zap itself. Getting this error:
 

Failed to create a channel message in Discord

ResponseError: {"status":403,"headers":{"content-type":"application/json"},"content":"{\"message\": \"Missing Permissions\", \"code\": 50013}","request":{"url":"https://discordapp.com/api/v9/channels/937780808855478283/webhooks"}}

 

I’ve tried creating a fresh zap, using fresh credentials/authentication. I’ve made sure that the bot has adequate permissions in my Discord server and in the channel it’s posting to. The RSS feed I’m trying to connect to is public: https://techcommunity.microsoft.com/plugins/custom/microsoft/o365/custom-blog-rss?tid=-8238675518584296925&board=CoreInfrastructureandSecurityBlog&label=&messages=&size=10

icon

Best answer by christina.d 30 June 2022, 19:37

View original

1 reply

Userlevel 7
Badge +9

Hey there, @ithius! Thanks for swinging by and highlighting the troubleshooting steps you’ve already taken! It’s super helpful.

It definitely sounds like you’ve hit a lot of the steps we typically recommend here in Community. At this point, I actually would recommend opening a ticket with my friends in support. They can a deeper look at your zap logs and hopefully help get to the bottom of this with you.

Please continue to keep us posted on your success! 

Reply