Best answer

"Couldn't log in with plugin" error in OpenAI GPT when using Zapier AI actions.

  • 11 November 2023
  • 37 replies
  • 2411 views


Show first post
This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

37 replies

Userlevel 2

I can confirm that it is now functioning properly for me! To resolve the issue, please log out and then log back into your OpenAI account. Afterward, proceed to run your assistant as usual. If it still appears as it did before, try clicking on the button or link again. This may prompt a new grant request, and once that's done, you should be good to go. The problem was related to a failure in the OAuth process, which resulted in the OpenAI API not responding to calls. 🚀

Userlevel 1

yes i ve noticed the same thing has any one solution ?

 

Userlevel 1

Hello everyone,

I've developed a GPT-based system designed to assist with responding to potential customer inquiries. Our process involves collecting information such as names, emails, etc., from customers and then storing this data in a Google Sheet. The system functions seamlessly on my computer and under my account.

However, I've encountered a puzzling issue. When attempting to use this system on a different computer or with a different ChatGPT account, it seems to require the user to have their own Zapier account. This is confusing because the integration and actions are set up under my Zapier account.

Why does the system require each user to have a separate Zapier account, even though they are accessing the GPTs actions set up in my account? Is there a way to configure the system so that others can use it without needing their own Zapier account?

Any insights or suggestions to address this issue would be greatly appreciated.

Thank you!

Userlevel 1

well actions even they are enabled → dont work. GPT can not conect wih gmail send mail or created doc. 

Userlevel 7
Badge +14

cc: @Reid 

Userlevel 7
Badge +14

@rudi.ranck 

GPTs are a brand new to OpenAI and to Zapier, so I expect there to be hiccups.

I don’t work for Zapier, so you can try opening a ticket with Zapier Support for possible assistance: https://zapier.com/app/get-help

Userlevel 2

@Troy Tessalone with all due respect, please stop giving this answer that to my knowledge is not helping anyone. What is being done to solve it.

Userlevel 2

has anyone solved it?

 

Userlevel 2

Have the same issu. enabled connections but can not send emails or create a doc. 

Userlevel 1

I have the same exact problem.

Userlevel 3

Hi @Troy Tessalone, Thank you very much for the help. I tried following the suggestions in the guide, but nothing changed. In the Actions of Zapier's GPT, there are 3 options for the type of authentication. The default settings are with OAuth authentication. In this case, however, I don't know where to find the "client ID" and "Client secret" values to enter. If I don't enter anything, it doesn't work. Then I tried the API connection type by entering my Zapier API key and selecting "Bearer" as the Auth type, but after clicking "Allow" again, I get the error "Couldn't log in with plugin". As a last attempt, I tried setting the authentication type to "None", but here too, no positive result. What would be the correct type of authentication? API or OAuth? If it's OAuth, which is the default for the Zapier action, should I leave the "client ID" and "Client secret" fields empty, or do I need to fill them with values? If so, where do I find them?

Userlevel 7
Badge +14

Hi @Lucadocet 

Good question.

This might be worth a try: