Best answer

AutoTask - Error while retrieving: The app did not respond in-time. It may or may not have completed successfully.


Hello, 

I’m getting this error only when I try to create a New Contact Zap from AutoTask to another platform. 

I get this message :

Error code: Error while retrieving: The app did not respond in-time. It may or may not have completed successfully.

That said, the update contact works fine but it only seems to pull one contact and no others. AutoTasks seems to pulling information from its find so I think this could be an issue with Zapier. Can anyone help?

icon

Best answer by rakhtar91 29 May 2024, 16:44

View original

14 replies

Hello, thank you for getting back to me. Currently it’s pretty simple,

Step 1: New contact in Autotask 

Step 2: Create Contact in Hubspot 

I’ve attach a screenshot of what I get currently. 

 

Userlevel 7
Badge +14

@rakhtar91 

Check your Zap app connection here: https://zapier.com/app/connections

 

You may need to try reaching out to Autotask Support for help with their Zap app integration:

https://ww1.autotask.net/help/Content/KB_Autotask/Integrations/KB370000000465.html

I’ve reached out to AutoTask initially, I managed to get my API systems picking up data in another zap with “update contact” but when I pick “New contact” there’s an issue.

I can show you that zap if you want? 

 

Connect shows as fine 

 

 

Userlevel 7
Badge +14

@rakhtar91 

You can try opening a ticket with Zapier Support: https://zapier.com/app/get-help

I’m currently using a free plan which isn’t letting open a ticket unfortunately. I would like to purchase a plan eventually but I don’t want to pay for something if it’s not working for the free plan if that makes sense. 

Userlevel 7
Badge +14

@rakhtar91 

Try creating a new Zap.

Try removing, then reconnecting the Autotask Zap app account.

Hello,

Just did this and it still doesn’t work unfortunately.

Any one can help with this? 

Userlevel 6
Badge +4

Hi @rakhtar91,

 

It’s nice to know that your Zap is working now as intended. We would love to see how you did it so other members can quickly return to this thread in case they encounter the same error message you experienced.
 

Userlevel 7
Badge +14

@rakhtar91 

You may want to try working with Autotask Support to explore the use of a webhook event for new contacts.

Zap trigger: Webhook - Catch Hook

This will generate a unique webhook URL to configure in Autotask.

Hi Troy - I managed to resolve it 

Userlevel 7
Badge +14

@rakhtar91 

Care to share how your resolved it for others that may come across this topic?

Had a play with some Zapier settings and it seemed to work after. Not sure exactly which setting fixed it to be honest. 

Userlevel 7
Badge +14

Hi @rakhtar91 

To help us have more context, post these screenshots:

  • how your Zap steps are outlined and configured in EDIT mode
  • encountered error

Reply