Best answer

Zapier had trouble retrieving custom fields from Google Docs.

  • 17 June 2020
  • 1 reply
  • 179 views

Hi! I received this message in my Create Document from Template step in Google Docs. It happens only when I use a custom value for the ID of the doc. If I specify a Template Document, it works fine!

 

Is it possible to retrieve fields using a custom value for the ID of the doc?

 

Thanks

icon

Best answer by nicksimard 19 June 2020, 01:44

Hi @aclmelo2!

I looked into this for you, and I see an existing bug report about this particular issue. I’ve added you as an affected user, so when it gets resolved you’ll be notified via email. To be fully transparent I believe this is a limitation of the Zap editor/the Google API, so I’m not sure how soon it will be possible.

Luckily, there may still be a way to work around this. As long as (a) the document template already exists and (b) the custom fields are the same, you can:

  1. Make a selection from the drop-down menu options
  2. The fields should then appear - map these fields out
  3. Revert the Template Document field to a custom value selection

This will throw you a warning that the custom fields are now extra (or something to that effect). Ignore that warning and click "Continue" and test the step out.

NOTE: this workaround can be finicky, but I figured I’d offer it in case you want to try it out.

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +10

Hi @aclmelo2!

I looked into this for you, and I see an existing bug report about this particular issue. I’ve added you as an affected user, so when it gets resolved you’ll be notified via email. To be fully transparent I believe this is a limitation of the Zap editor/the Google API, so I’m not sure how soon it will be possible.

Luckily, there may still be a way to work around this. As long as (a) the document template already exists and (b) the custom fields are the same, you can:

  1. Make a selection from the drop-down menu options
  2. The fields should then appear - map these fields out
  3. Revert the Template Document field to a custom value selection

This will throw you a warning that the custom fields are now extra (or something to that effect). Ignore that warning and click "Continue" and test the step out.

NOTE: this workaround can be finicky, but I figured I’d offer it in case you want to try it out.