Question

Wordpress Create New User - Custom Role assignment adding two roles instead of 1

  • 2 June 2021
  • 6 replies
  • 102 views

[Sorry, title should read “two roles” not “to roles”!]

Hello. I’m trying to use the Wordpress Create User zap. I use a membership plugin called s2Member. S2Member adds new additional custom role options (s2Member Level 1, s2Member Level 2, etc.).

In the zap setup, for the “Role” field, I entered a custom value of “s2member_level1”. This successfully attributes the “S2Member Level 1” role to the new user account created by the zap. 

However, the zap is also attributing a 2nd role to the user: “Subscriber”. This is not something that I want. I only want the custom role to be attributed in the zap. 

Can anyone help with this? See images below. Thanks!

 

 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

How did you manage to get custom roles to work?

 

On my end Zapier just throws a 400 error when I try to use a custom role….

Userlevel 3
Badge +6

Hey @davidcom, I hope you’re doing well, I just wanted to check in here!

I saw on the ticket where you did some work with one of our support members and they referred you to S2 with some logs.

Were you able to get this issue sorted out?

Let us know if they had some good info to share in case anyone else is seeing this trouble.

Have a great weekend!

Userlevel 7
Badge +11

Hi @davidcom 

Per WordPress documentation: https://wordpress.org/support/article/roles-and-capabilities/

Subscriber (slug: ‘subscriber’) – somebody who can only manage their profile.

Hi @Troy Tessalone. Thanks for the input. However, I wasn’t so much needing a definition of Subscriber, but rather I was looking for a way to keep the zap from attributing the Subscriber role in addition to the s2Member role. A user should only have 1 role. My Zap settings attributes the S2Member role. But the zap is also attributing the Subscriber role. See image below.

 

 

Userlevel 7
Badge +11

Hi @davidcom 

Might be best to open a ticket with Zapier Support for them to chime in on this: https://zapier.com/app/get-help

Could be a native setting in the WordPress Zap app integration.

May have to explore using the WordPress API to work around this: https://developer.wordpress.org/rest-api/

Thanks @Troy Tessalone. I submitted a ticket.