Best answer

Unbounce and SendGrid - Rejecting API Key Login for SendGrid

  • 9 March 2020
  • 2 replies
  • 133 views

Userlevel 1

Attempting to connect Unbounce to Sendgrid. Zapier rejects the Sendgrid Pro Account API Key with the error "not allowed". An API key with admin permission was attempted, then one with email only, neither worked. A new teammate and API Key were also attempted. The error message reports "set to allow or approve", but doesn't say where to do this. My API Accounts are approved in Sendgrid. I can't see the advantage of Zapier compared to Webhooks at this point. Help appreciated.


icon

Best answer by jesse 11 March 2020, 03:50

Hey @zapjohn sorry to hear you're running into some issues here! I see you've also written into our support team and that they're investigating but I have a few questions for you that might help us get to the bottom of this:

  • Check if there are special characters in the password (characters like $ and &). If there are, can you try changing the password to one without special characters and see if that can authenticate?
  • Can you confirm you're not in a trial with Sendgrid, currently?
  • Lastly, although this may seem counterintuitive, can you check to make sure the user/teammate you set up is not listed as an admin?  Admin accounts don't appear to have the needed permissions for this to work so you'll want to set a custom permission account instead.

Let us know if any of those help to troubleshoot this for you!


View original

This topic has been closed for comments

2 replies

Userlevel 7
Badge +10

Hi @zapjohn

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.


Userlevel 7
Badge +8

Hey @zapjohn sorry to hear you're running into some issues here! I see you've also written into our support team and that they're investigating but I have a few questions for you that might help us get to the bottom of this:

  • Check if there are special characters in the password (characters like $ and &). If there are, can you try changing the password to one without special characters and see if that can authenticate?
  • Can you confirm you're not in a trial with Sendgrid, currently?
  • Lastly, although this may seem counterintuitive, can you check to make sure the user/teammate you set up is not listed as an admin?  Admin accounts don't appear to have the needed permissions for this to work so you'll want to set a custom permission account instead.

Let us know if any of those help to troubleshoot this for you!