Question

Two zaps with the same trigger on one Linkedin LeadGen form

  • 2 December 2021
  • 3 replies
  • 27 views

Hi,

I am having issues on a Zap with a Linkedin LeadGen Form trigger:

I have an older Zap activated and working on a Linkedin form. This one captures form responses and stores them in a google sheet. 

Now I am creating a new Zap, that has the exact same trigger (Leadgen Form Response) on the exact same Linkedin form. It passes the form response data to another platform using a custom webhook. However, when I activate this new zap, nothing happens when I get a new form response. The old zap still works though. 

 

When I test my new Zap, it does find new form responses to test with. So it looks like the connection is valid. The webhook alsio works fine. But when I activate my Zap and enter new form responses, the trigger does not get triggered. 

 

Are there limitations on the amount of identical triggers on a single Linkedin Form? 

 

Thank you.


3 replies

Userlevel 7
Badge +12

Hi @Ingeborg 

Check the available help articles: https://zapier.com/help/doc/common-problems-linkedin-lead-gen-forms-zapier

Hi @Troy Tessalone ,
Thank you. However, I am still receiving testdata and the connection with Linkedin is live (I have tested it to verify). 

I also have the correct Linkedin permissions. 

 

Userlevel 7
Badge +12

Hi @Ingeborg 

A possible workaround to try... 1 Zap with multiple action steps instead of separate Zaps.

 

If you still need help, consider opening a ticket with Zapier Support: https://zapier.com/app/get-help

Reply