Best answer

Trouble connecting Messenger to Help Scout

  • 4 August 2020
  • 3 replies
  • 51 views

Userlevel 1

Hi guys, so as the title suggests, I'm having some issues with connecting Facebook Messenger to Help Scout via Zapier.

 

  • I've successfully connected the Messenger of my Facebook page to Zapier.

  • I've successfully connected my Help Scout account to Zapier.

  • All fields have been added correctly and double-checked for errors.

 

However, I get an Error 400: Bad request. Any idea what's going on?

I'm NOT the admin of the page; just an editor. Could that be an issue? Any help would be appreciated.

icon

Best answer by Liz_Roberts 12 August 2020, 15:25

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +10

Hi @ShawnHV 

As I mentioned on Reddit, I believe you’ll need to be page admin for this to work.

That said, the error message is a little confusing, so I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 1

Thanks again! 

Userlevel 7
Badge +7

Hi @ShawnHV ,

Thanks for reaching out!

I see you were working with Kaushi in Support on this and they have added you to a feature request as there is a limitation with the "New Message Sent to Page" Trigger because it does not return the email of the person who sent the message. This in turn prohibits you from using the Find User Action of HelpScout.

Should there be an update on this Trigger, you will be notified via email! Sorry we don’t have better news there, but please let us know if you have any additional questions!