Best answer

Stripe currency changes to Xero default

  • 12 July 2021
  • 5 replies
  • 22 views

We have a ZAP that imports invoices from Stripe into Xero.

 

However, our client uses multiple currencies, but when the ZAP imports the stripe invoice into Xero, the currency is defaulted to GBP, how can we resolve this please.#

 

thank you

icon

Best answer by GetUWired 27 July 2021, 14:45

You will need to fill out the currency field on the Xero step so that it doesn’t default to GBD. This should be passed dynamically from Stripe. 

If the way Stripe formats currencies is not the same as the way Xero formats currencies. A look up table will be needed to translate the values. More info on using a lookup table can be found here: https://zapier.com/help/create/format/create-lookup-tables-in-zaps 

View original

5 replies

Userlevel 7
Badge +11

Hi @hellombw 

Check if there is a setting in the Zap step configuration for specifying the currency.

Userlevel 7
Badge +10

Hi @hellombw 

You will need to tell Zapier to dynamically determine the currency when generating the invoice in Xero. I.e pass the currency type returned from the trigger step into the currency type in Xero

If the currency type returned from the trigger step doesn’t match what xero is calling it, you will need to implement a lookup table to translate values 

There are a number of fields in the Zap that i can select from Stripe, but we are still seeing the default currency when the invoice is created in Xero. Not entirely sure how to use the formatter,

Userlevel 7
Badge +10

You will need to fill out the currency field on the Xero step so that it doesn’t default to GBD. This should be passed dynamically from Stripe. 

If the way Stripe formats currencies is not the same as the way Xero formats currencies. A look up table will be needed to translate the values. More info on using a lookup table can be found here: https://zapier.com/help/create/format/create-lookup-tables-in-zaps 

thanks everyone for your response, the zap is now working as we need it to. it was more a case of selecting the correct field from stripe for the currency

Reply