Best answer

MySQL Version 8

  • 23 December 2020
  • 24 replies
  • 313 views

Userlevel 1

Anyone know when MySQL version 8 will be working and if there is a workaround?

icon

Best answer by Danvers 30 July 2021, 19:25

Hi everyone!

I do have an update on this issue, but I’m afraid it isn’t good news.

I spoke to the team at Zapier that handles this integration and they confirmed that it’s unlikely that they will add support for MySQL version 8 in 2021. I’m sorry, I appreciate that this isn’t the news that you’ll want to hear, but I want to be transparent about our expectations for when this will be addressed. 

 

If anyone is new to this thread, please do check out the workaround the @william posted below. We know that it has worked for some users, though not all. 

View original

24 replies

Userlevel 7
Badge +9

I don’t know, sadly - It may be worth reaching out to the team behind the most recent version to see if they have any plans to release a new version. Zapier only creates and maintains a few key integrations, but most of the integrations out there are maintained by the apps that they integrate with

Anyone know when MySQL version 8 will be working and if there is a workaround?

I would like to see it happen too

bump bump. me too. Even an update would be nice. what is the error and how do we fix it. I am waiting to sign up until they support mysql 8

Userlevel 7
Badge +10

Hi @jazzhands @carlaogenteboa @MoreTrees!

This one is maintained by Zapier, and there’s an existing feature request for us to support MySQL 8.0+. I’ve added all of you to the request, so when it gets implemented you’ll be notified via email. 

any news?

 

Thanks

Userlevel 1

Would really like to see this happen as well, we are upgrading environments to mysql 8 and not having this integration set up - may force us to go elsewhere for our Zaps!!!

 

Help!!!

 

Userlevel 7
Badge +7

@gadiaz1 @iberkner I have added you both to this request. While I don’t see an ETA, you will be notified via email with any updates! 

@Liz_Roberts Can you add me to your update list for MySQL 8?  we are looking to purchase the service once we are able to do this.

 

Userlevel 7
Badge +8

Hi @RipCurlXV - I’ve added you to the update list. Thanks!

Userlevel 1

Hi there, this is also problematic for us - since upgrading we are unable to use our Zaps, either, and may have to investigate an alternative provider. MySQL 8 has been out more than 3 years, now, it wasn’t even on our radar that Zapier might still not support it.  I have tried setting the type of password authentication for the MySQL user back to the old style, but that hasn’t helped.

Userlevel 1
Badge

@Latitude91 You’ve been added to the report! We appreciate your patience!

Userlevel 1

Hi,

I don’t get it.

Why is this either being ignored and / or not handled / attended to by the Zapier team? This makes no sense.

Any clarity on that would be greatly appreciated.

Thanks

Userlevel 1

Seconding this - it’s 6 weeks since you “added us to the report” but there seems no sign of progress? That’s /not great/ even ignoring the fact it was already 3 years since v8 was released. MySQL is the second most popular DB in the world, this zap integration allows for the connection of all *kinds* of different websites and applications that you will never be able to code for individually. It’s an absolutely critical connector for Zapier. This should be a flashing P0 issue right the way up to senior management, surely?

Userlevel 1

At minimum, a status update on this topic would be appreciated, not the way to treat paying customers.

Will start considering alternative solutions prior to renewal of our subscription if no additional information on this topic is provided in a reasonable and timely matter.

Thanks

Userlevel 3
Badge +6

Hey @Latitude91 and @iberkner, hope you are well!

For this particular issue the trouble is due to the changes in authentication and the API with version 8+, as you may be aware.

Potential Workaround:

One of our users let us know they were able to work around this limitation by configuring their database with "defaultauthenticationplugin=mysqlnativepassword" to ensure backward compatibility, so the connection issue cannot be caused by the authentication protocol itself. They suspected this issue is caused by the queries the DB performs after login (it selects @@txisolation which has been removed in MySQL 8.0). Remapping it via a proxy did the trick

In regards to how we do maintenance and improvements on integrations:

Zapier has many apps that are maintained by our team and those apps each have feature request and bug reports that require attention and have to be prioritized.

These issues and requests are prioritized based on a number of factors, including number of interested users and the impact of that issue. 

Since MySQL is a more technical tool that is used by fewer people, there have been fewer requests for features and updates over time, so priority increases slower. 

That does not mean we’re ignoring the request, but it does mean that the order things are address and added in is very heavily tied to the interest and issues of all Zapier users across all integrations we manage, not individually.

I can definitely understand that a 3 year old feature may seem like it has had no movement, but we actively track interest in this functionality and we’re adding users to the list to increase the priority of the request. This particular feature is slowly moving its way up our priority list as more interested users come through.

That said, there are still several other requests across our integrations that are ahead of this feature because of this global prioritization.

I can 100% confirm that you are both on the interested user list for this feature update. We’ll be sure to alert you ASAP once we have more to share.

Userlevel 1

Hi there, this is also problematic for us - since upgrading we are unable to use our Zaps, either, and may have to investigate an alternative provider. MySQL 8 has been out more than 3 years, now, it wasn’t even on our radar that Zapier might still not support it.  I have tried setting the type of password authentication for the MySQL user back to the old style, but that hasn’t helped.

Per our original comment, setting to “mysqlnativepassword” did not (for us at least) solve the connection issue.

Can I confirm then, from your response, that the current state of this issue is that you are not actively working to fix it and that you have no immediate plan to do so until enough people complain?

I appreciate that you say you’ll update “ASAP once you have more to share”, but if there’s no likelihood that you’re ever going to do that, then it seems like you should give your paying customers that clarity, so that we know to solve these integrations a different way, rather than waiting for a fix.

Userlevel 3
Badge +6

Hey @Latitude91, thanks for the comment!

If the workaround didn’t work, then you’ll need to wait for engineering resources to become available to implement the new functionality. The current state of the issue is that the feature is on our list of new features to add but there are other features that are ahead of it.

This particular issue is not a bug, it is due to the integration not supporting newer versions of MySQL. I can understand that it can be frustrating to have to wait for new functionality, especially when that functionality is older. However, before we can support MySQL v8+, the integration will need to be updated.

This isn’t about waiting for user’s to complain, it is about user interest in a feature and how engineering resources are prioritized. I felt that providing you with insight on how new functionality is prioritized would serve you better than ignoring you request for more information.

The clarity you are referring to is the clarity I was seeking to provide. If this feature is a critical requirement for your workflows, the feature is not available at this time and may not be added in the immediate future. Any time a feature is missing and is required for your business, we recommend you do what is best for your business now than wait for a fix.

I definitely apologize for the frustration here, but I did not want to leave your questions unanswered.

 

Userlevel 1

@william so a few comments…

  1. Unless I missed it in this particular thread or anywhere else that I looked, I did not see the workaroundt that you suggest was previously mentioned somewhere. We have not tried this yet, will try it, but my hopes are not high.
  2. Your suggestion that “fewer people” are using MySQL is wholly inaccuarate and I’m really not sure where its coming from, as compared to what? MySQL is usually in the top 3 of databases used based on market share. Clearly at some point Zapier felt it was important to build integration into this RDBMS, so why not maintain it ahead of NEW FEATURES? 
  3. If the “integration” is the issue, isn’t that code that the Zapier team is responsible for?
  4. Baseline connectivity to a new version of a previously integration tool should not be simply discarded ahead of many other features - yes - I understand that there are business priorities, etc. but it just doesn’t make sense that Zapier does not move this to the top of the list.
  5. I understand this is “not a bug” but its essentially rendering a core feature and seeling point, i.e. integratoin with MySQL unavailable to anyone who’s policies or business needs require them to upgrade to later versions of software and tools to remain compliant outside of EOL of a system.

At this time, I’m not sure what we’re going to do, this is critical to our business needs, and we may not be able to continue using Zapier (as I previously mentioned) unless this is fixed.

I’m not sure why at least an ETA can’t be provided.

Anyway, thanks.

Userlevel 3
Badge +6

Hey @iberkner, I hope you’re doing well!

Thanks for the comments, I’ll be happy to touch on each in order here:

  1. Glad I could provide the info!
  2. This is in relation to the number of users that use other integrations on Zapier and ask for features they want or need to be added. This isn’t in relation to the number of people that use MySQL globally. When referring to number of users, that is specifically related to the number of Zapier user’s asking for this feature. MySQL is definitely a very popular app globally, I’m referring to usage within Zapier only.

    In regards to maintaining the integration, this is something we do for every integration that Zapier maintains. However, new features are based on user demand as Zapier does not maintain one single integration like most developers, but several dozens of integrations each with potentially dozens of feature requests with their own user demand. We do not count the needs of one user higher than another, but on a platform with thousands of integrations, prioritization is a requirement to function.
     
  3. Yes, the latest version of MySQL changed the default auth schema which requires the integration to be updated for it to work with the latest version.
  4. We do not discard feature requests or bug reports from users at any point in our management of integrations on Zapier. They are prioritized based on many factors, including user interest and demand. There are other features ahead of this one based on that prioritization. I know that this can seem unfair, and I apologize for the hassle.
  5. That is correct and we understand that this is a decision that business have to make based on their priorities. This is not something that we nefariously set out to punish users for and we understand that business needs may force the hand of some users to do what is best for their business.

    We do not take our user’s or their needs lightly, you and all of our users are what make Zapier the platform it is.

    That said, prioritization has to be done in all business in order to do the most good for the most people the most often and that is what we strive to do. This is not about diminishing the value of you or any other user at Zapier, it is about doing the best we can for as many of you as we can with the resource we have at any given time.

In regards to an ETA:

This isn’t given because engineering resources are allocated based on that dynamic priority. The priority changes based on user demand and impact. The more users that report an issue or request a feature, the faster a feature or bug tracks up the priority list.

The best way to increase the priority of a feature is to have more people cast their vote by reporting to this thread or writing into our support team. If you know other users that need this feature and have not asked for it, have them write to us so we can count their vote. That will increase the priority of the request and help us push this request forward faster.

I appreciate you taking the time to write out your thoughts here and share your comments. Again, this is what makes Zapier great, user’s sharing their needs and their thoughts with our team so that we can best prioritize our actions.

I apologize that this particular issue is causing a headache for you and your team and I understand that you have to do what is best for your business. Let me know if you have any more questions, and feel free to send any other Zapier users interested in this feature update to our thread here so we can count their vote!

 

All the best,

Since we don’t have any ETA the solution that i found is simply to use ProxySQL to proxy request to the Mysql 8.0 database. 

But even in this case you will need to tune proxy since in MySQL 8.0 depricated some variable. 

 

This is rules that I am used to make it work. You need to replace variable @@tx_isolation in query with @@transaction_isolation.

The rest of the confguration is default and can be found on ProxySQL website.

Maybe it will help someone.

Userlevel 5
Badge +8

Thanks for sharing your workaround here, @Freshmethod! :)

Hi Team, I too am waiting MySQL V8 support. Pls add me to the update list. The workaround outlined above didn’t seem to work for us.

Regards,

Steve

Userlevel 5
Badge +8

Hey @TotalSteve,

Sorry the workaround didn’t solve things for you here. Happy to confirm that I’ve added you to the update list as well.

We’ll be in touch as soon as we have an update on this! :)

Userlevel 7
Badge +11

Hi everyone!

I do have an update on this issue, but I’m afraid it isn’t good news.

I spoke to the team at Zapier that handles this integration and they confirmed that it’s unlikely that they will add support for MySQL version 8 in 2021. I’m sorry, I appreciate that this isn’t the news that you’ll want to hear, but I want to be transparent about our expectations for when this will be addressed. 

 

If anyone is new to this thread, please do check out the workaround the @william posted below. We know that it has worked for some users, though not all. 

Reply