Question

Mailchimp Tag Issue - Resource Not Found


Hi all,

I’m trying to setup a Zap to send an email to sales once a subscriber gains a particular tag (assigned from a mailchimp landing page). The tag doesn’t list in the setup so I entered the EXACT text of the tag from Mailchimp into the custom value. When I go to test the trigger I get a red error that says “A subscriber could not be found Resource Not Found - The requested resource could not be found.” 

Anyone have any ideas?


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12 replies

Userlevel 7
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Hi @MWu 

Please post screenshots of how your Zap step is configured, thanks.

 

Hi @Troy Tessalone thanks for your reply here is the configuration

 

 

Also here is the error

 

 

Userlevel 7
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@MWu 

Error: "Resource Not Found - The requested resource could not be found."

Last updated: June 01, 2020

Symptoms

This error can occur in both the "Send Data" step when setting up your Zap or in an errored Task when the Zap is running if a Mailchimp resource was not found. A resource refers to a specific object in Mailchimp such as a specific tag or audience.

Causes

It's possible a resource included in your Zap was moved or deleted from Mailchimp, or there was a typo in a field where you provided a custom value. This error can also occur when trying to load options for a dropdown field that depends on you having selected a value in a previous, required field.

How to fix it

  1. Confirm you have all the required fields filled out in the Zap.
  2. If you've provided a custom value for any of your fields, confirm the values are correct, especially IDs. The field may be expecting an ID, when you've provided the name of the value.
  3. If you still see this error, confirm the resource (whether it's a tag, audience, etc.) still actually exists in the Mailchimp account connected to the Zap.

@Troy Tessalone thanks for this. I guess it is possible im not using a correct ID. Everything is filled out and I still have the tag in mailchimp. Any idea what the ID string could be?

Userlevel 7
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@MWu 

It may take a bit of time for the MC Segments/Tags to become available if you just added them in Mailchimp.

 

Try clicking the [Load More] button in the Segment or Tag dropdown.

 

Also try clicking the [Refresh Fields] button on the Zap step.

 

@Troy Tessalone unfortunately I’ve tried this several times. I also added the tag over 24 hours ago. :sweat_smile:

Userlevel 7
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@MWu 

Try using a dummy Subscriber in Mailchimp and add that Subscriber to the Tag or Segment to see if that refreshes the available options in the dropdown list.

@Troy Tessalone tried this yesterday too and then refreshed and tried to load more without any luck

 

Userlevel 7
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@MWu 

Might be best to open a ticket with Zapier Support: https://zapier.com/app/get-help

Userlevel 7
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@MWu

I tested on my own Mailchimp account and Zap account.

I added a New Tag to the Mailchimp Audience, then click the Load More button in the Segment or Tag dropdown field in the Zap, which pulled thru the new Mailchimp Tag to select.

Same for Segment, and that worked.

@Troy Tessalone im wondering if it has something to do with creating the tag via a landing page. The audience matches the one i selected in the setup you can see the tag that is highlighted. It just will not show up in the dropdown in Zapier

 

Userlevel 7
Badge +14

@MWu 

Might be best to open a ticket with Zapier Support: https://zapier.com/app/get-help