Best answer

iAuditor not finding any report templates

  • 14 August 2021
  • 3 replies
  • 16 views

I am wanting to integrate iAuditor with Dropbox - sending reports to a Dropbox file once completed in iAuditor. I have several inspections completed in iAuditor however when I go to set up a trigger it says that there are no reports templates in iAuditor to even test a trigger. In other words, the reports exist in iAuditor but zapier doesn’t seem to recognise them. Any help appreciated!

icon

Best answer by SamB 14 October 2021, 15:36

View original

3 replies

Userlevel 7
Badge +11

Hi @shanchalk 

Certain audits are not being triggered

As you only have access to audits that you have permission to view, you must have view permissions for all audits that you intend for Zapier to trigger an alert. To automatically have audits shared to you, please consider configuring auto-sharing on each of your templates.

If you have view permissions for audits and they are still not being triggered on, ensure that users are marking the audit as complete. Audit’s will only be triggered on if they are marked as complete.

My template is not appearing in the template drop down list

Only the 20 most recently used templates will be shown. This means that you must have completed an audit for a template to be shown in the list. Once you have completed an audit for your template, refresh the page and your template should appear in the drop-down list. See the next note for how to find the Template Name ID so you can use it as a Custom Value.

Thanks so much for your reply Troy. The inspections have been completed multiple times (reports available) and the iAuditor access for each inspection report is set for all users. The templates don’t show up, instead an error message comes up that says: “we’re having trouble loading “template name” data (the app returned “insufficient scope”.) 

Userlevel 5
Badge +8

Just wanted to follow up here for anyone also running into this issue to note that the “insufficient scope” error tends to indicate that there’s an issue with the permissions of the connected iAuditor account.

You’ll want to ensure the connected account is and admin account and has the following permissions are granted for the templates you’re wanting to select:

  • Data Management
  • Data Access
     

More details on how to set those permissions can be found here: How to assign and manage organization permissions 

Then, once those permissions have been granted you’ll need to reconnect the account so that we’re connecting to iAuditor with the updated permissions.

Reply