Best answer

HubSpot hidden fields no longer visible

  • 18 March 2020
  • 8 replies
  • 246 views

Userlevel 1

Hey :)

We always used HubSpot hidden form fields for UTMs etc. but since yesterday they just disappeared.

We use them for FB/ LinkedIn Lead Gen Forms, which then create a new form submission within HubSpot.

 

Is anyone facing the same issue? 

 

Looking forward to some answers..

Best! 

icon

Best answer by steph.n 18 March 2020, 23:49

Hell @Spryker, thanks for writing to our community today! Happy to help here.

It looks like you found a bug. However, I noticed you submitted a ticket to Shalyn from Zapier support about this issue. So that we may help others that may have the same question as you, I’m going to post what was sent to you here so that others may follow along:

 

The good news is you're not the first user to request this so it's on our radar. I’ve added your name as a vote for this feature which does the following:

  • Re-raises the request with the dev team
  • Gives us a place to track user interest on our end
  • Reminds us to notify you once this become available

We don’t have an ETA of when or if this will happen, but we will definitely email you should we have an update to share with you. Keep an eye out for our Zapier Updates in your inbox or on our blog by clicking herehttps://zapier.com/zapbook/updates

 

Thanks!

View original

This topic has been closed for comments

8 replies

Userlevel 7
Badge +8

Hell @Spryker, thanks for writing to our community today! Happy to help here.

It looks like you found a bug. However, I noticed you submitted a ticket to Shalyn from Zapier support about this issue. So that we may help others that may have the same question as you, I’m going to post what was sent to you here so that others may follow along:

 

The good news is you're not the first user to request this so it's on our radar. I’ve added your name as a vote for this feature which does the following:

  • Re-raises the request with the dev team
  • Gives us a place to track user interest on our end
  • Reminds us to notify you once this become available

We don’t have an ETA of when or if this will happen, but we will definitely email you should we have an update to share with you. Keep an eye out for our Zapier Updates in your inbox or on our blog by clicking herehttps://zapier.com/zapbook/updates

 

Thanks!

I can attest to other fields that just suddenly disappeared a few hours ago including the Company Associated ID field in the new hubspot integration app. 

 

Please advise!

Userlevel 7
Badge +11

Hi folks! I’m sorry that you’ve run into this trouble with your Zaps. It looks like this might be a new bug that we’re seeing and we’re currently looking into this to see if we can get to the bottom of it. 

I’ll add an update here when we have some more information. 

Userlevel 7
Badge +7

Hi @marwan_roxova ,

Circling back here with an update!

This seems to be an issue with updated HubSpot API not returning these fields.

If you happen to have a Zap connected to the “Legacy” version of HubSpot, you can copy this over and these hidden fields should be visible.

Another workaround we have seen is opting to “unhide” the fields in question which brought them through. 

I hope these options help you achieve your workflow! Please let us know if you have any further questions- happy to help!

Userlevel 1

Hi @Liz_Roberts 

 

sorry, but could you please explain this: 

If you happen to have a Zap connected to the “Legacy” version of HubSpot, you can copy this over and these hidden fields should be visible.

 

I don’t really get it which I still don’t know what to do..

 

Thanks!

Userlevel 7
Badge +7

@Spryker sure thing! This is what we have seen one user do:

 

If you have an existing Zap that is currently leveraging the previous version of the HubSpot integration (“HubSpot Legacy”), you can copy that Zap in order to sidestep the hidden fields issue. 

  1. To check if you have any Zaps using HubSpot Legacy go to your My Apps page and search for “Legacy.”
  2. You can then see if any Zaps appear with HubSpot (Legacy).
  3. If you find one, click “Copy” from the Zap dropdown and build your desired Zap from that copy. 

 

Here’s a quick video of the above steps (the Zap in my example uses Formatter Legacy, but still the same steps).

 

Hoping this workaround proves helpful! Please keep us posted :relaxed:

Userlevel 1

Hello @Liz_Roberts 

 

thanks, we’ll try that as I found some old “Legacy” Zaps.

But will there still be a proper fix for that? We use “Hidden Fields” within every Zap and can not “unhide” those on Hubspot…

Thank you and sorry for the back and forth..

 

Userlevel 7
Badge +7

Hi @Spryker ,

More than happy to help! Our Support team has opened up an issue with the Hubspot team to see if these hidden fields can be added back.

To give you some context, the Hubspot app is developed and maintained by the people who make that product. However, we track issues and feature requests like this in a system that lets the developers at Hubspot know when we receive a bug reports from folks like you. It also lets us email you when any changes or updates occur. Other users have also reported this issue, so I have added both you and @marwan_roxova  to the existing report for it. While I can’t say for certain when/if this will get added, I can promise that we’ll let you know when/if it’s rolled out!

While we will keep pushing on this end, I highly recommend that you reach out to Hubspot and request that they implement this feature. Our partners generally respond more quickly when they hear from their own customers and it’ll raise the visibility of your needs! 

Please reach out with any additional questions- I will update this thread with any new workarounds or solutions!