Best answer

How to solve "Upload media in Wordpres: The app did not respond in time"?

  • 12 August 2020
  • 5 replies
  • 226 views

Userlevel 1

I am trying to upload an image from Cloudconvert to Wordpress, create a post and attach the image as featured media. When trying to upload the image (png) to Wordpress I run into a timeout error: "The app did not respond in-time. It may or may not have completed successfully."

The image almost always uploads to Wordpress successfully, but I can't attach it as a featured media in a post because I don't get the output data which includes the image id that I need to be able to attach the image to a post as featured media.

Does anybody know what could be causing the problem and a way to work around it?

icon

Best answer by Kurios 13 August 2020, 07:05

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +9

Just by way of testing this, have you tried reducing the size of image and seeing if that makes a difference? If it does, it might be worth amending the size of the image before uploading it.

Userlevel 1

Hi Andy,

 

Thanks for your answer. I have tried using tinypng to compress the image before uploading it, but I still get the same error.

Userlevel 7
Badge +9

That’s very frustrating. I think this sounds like a bug, honestly - So might be a good idea to either reach out to Zapier, or even the developer of the Zapier WP app to see if they can help you/

 

Sorry I couldn’t be of more help here. IF you get a solution, would you mind posting it back in the thread?

Userlevel 1

It seems that it was a Wordpress plugin what was causing the error. I was using the plugin "Smush" to compress my images and when I deactivated it the zap worked perfectly without an error.

Userlevel 7
Badge +10

Thanks for letting us know, @Kurios! Glad you were able to figure it out :)