Best answer

Gravity Forms Connection error

  • 11 March 2021
  • 65 replies
  • 1206 views

Hello,

I keep getting Base URL invalid when try to connect Gravity forms app (Auth 2.0)

icon

Best answer by nicksimard 13 March 2021, 00:01

Hi @Eyal!

Happy to see that you’ve reached out to our Support team and they’ve helped you out with this. 

For anyone else who finds this thread, here’s what Support had to say:

Invalid Base URL error looks to be a bug with this app. The good news is you're not the first user to report this problem and it's on our radar. I’ve added your name to this issue which does the following:

  • Re-raises the request with the dev team
  • Gives us a place to track users affected
  • Reminds us to notify you once this become available


I don’t have an ETA of when or if this will happen, but we will definitely email you when this is fixed! Keep an eye out for our Zapier Updates in your inbox.

It may be best to reach out to them if you run into this error, since it may not always be the case that it’s related to this bug.

View original

65 replies

Userlevel 7
Badge +10

Hi @MEMT!

I've gone ahead and added you to the list of affected users. We'll let you know via email when that's been resolved!

@Danvers can you add me to, i have the same issue. Running GF 2.5, openlitespeed and cloudflare. thanks!

Userlevel 7
Badge +11

Hi @Jon Korn, I’ve added you to the list of affected users - thanks!

@Jillian Can you add me as well. I am using CloudFlare and we are unable to connect Gravity Forms.

Userlevel 3
Badge +6

Hey @Frontpor, I hope you’re doing well!

Thanks for the the comment and the great info, I’ve just added you to the affected users list and we’ll be sure to alert you ASAP once there is a fix. 

Hi, 

We are also being affected by this issue.

We’ve followed the suggested solutions on this thread (removed htaccess entirely, disabled cloudlfare) but none of them worked so far.

This is the log we get: 

2021-07-12 11:25:52.334181 - DEBUG --> GF_REST_Authentication::authenticate(): Running. 
2021-07-12 11:25:52.334913 - DEBUG --> GF_REST_Authentication::perform_basic_authentication(): Running. 
2021-07-12 11:25:52.334978 - ERROR --> GF_REST_Authentication::perform_basic_authentication(): Aborting; credentials not found. 
2021-07-12 11:25:52.335010 - DEBUG --> GF_REST_Authentication::perform_application_password_authentication(): Running. 
2021-07-12 11:25:52.335042 - ERROR --> GF_REST_Authentication::perform_application_password_authentication(): Aborting; user not found. 
2021-07-12 11:25:52.335067 - DEBUG --> GF_REST_Authentication::perform_oauth_authentication(): Running. 
2021-07-12 11:25:52.335108 - ERROR --> GF_REST_Authentication::perform_oauth_authentication(): Aborting; OAuth parameters not found. 
2021-07-12 11:25:52.335973 - DEBUG --> GF_REST_Controller::current_user_can_any(): method: GET; route: /gf/v2/zapier-requirements; capability: "gravityforms_edit_forms"; result: false. 
2021-07-12 11:25:53.388849 - DEBUG --> GF_REST_Authentication::authenticate(): Running. 
2021-07-12 11:25:53.388952 - DEBUG --> GF_REST_Authentication::perform_basic_authentication(): Running. 
2021-07-12 11:25:53.388988 - ERROR --> GF_REST_Authentication::perform_basic_authentication(): Aborting; credentials not found. 
2021-07-12 11:25:53.389014 - DEBUG --> GF_REST_Authentication::perform_application_password_authentication(): Running. 
2021-07-12 11:25:53.389041 - ERROR --> GF_REST_Authentication::perform_application_password_authentication(): Aborting; user not found. 
2021-07-12 11:25:53.389065 - DEBUG --> GF_REST_Authentication::perform_oauth_authentication(): Running. 
2021-07-12 11:25:53.389101 - ERROR --> GF_REST_Authentication::perform_oauth_authentication(): Aborting; OAuth parameters not found. 
2021-07-12 11:25:53.390002 - DEBUG --> GF_REST_Controller::current_user_can_any(): method: GET; route: /gf/v2/zapier-requirements; capability: "gravityforms_edit_forms"; result: false. 

I’d like to be added to the issue to get notifications on it. 

Thanks.

Userlevel 7
Badge +10

Hi @SunsetSpas!

I’ve gone ahead and added you to the list of affected users.

 

Same issue here

Userlevel 3
Badge +6

Hey @WURLIN, hope you’re well!

I’ve just added you to the affected user list so that we can be sure to alert you ASAP once the issue is resolved.

Also having this issue...

Userlevel 1
Badge

@U.S. Energy Recovery You've been added to the report! Once we have an update you’ll be notified directly!

We’re also having this issue. Is there an update for this yet?

 

Userlevel 7
Badge +10

Hi @RootCause!

I think as far as Bot Fight Mode is concerned, your best bet would be to reach out to the Gravity Forms support team to see if they can confirm that for you. They also have their own Community, where you might be able to find help with that :)

Disabling Bot Fight Mode in CloudFlare fixed it for us.

Obviously this isn’t the ideal solution as we’d like to maintain that CF functionality. Is there an official response to keeping Bot Fight Mode turned on?

Userlevel 3
Badge +6

Hey @Mark Dalton

I just added you to the bug report and we’ll be sure to alert you ASAP once this is resolved!

Add me to the list too. Not working and holding up the release of several new site elements.

Userlevel 3
Badge +6

Hey @Anne, hope you are well!

I’ve just went in and made sure you were added to the report so that we can be sure to alert you ASAP once there is a resolution.

In the meantime, if you need access to the IP address range for Zapier, that would be all of US-East-1 from Amazon: https://zapier.com/help/troubleshoot/behavior/cant-access-or-use-zapier-with-other-apps

The issue would not be explicitly related to CloudFlare firewall, but any firewall that may be configured to block our IP address range. Sometimes hosts of a domain may automatically have blacklisted IPs from Amazon and this can cause issues as well.

That said, this particular bug is a top priority right now and we are actively working with Gravity Forms to help find a resolution for all of our users. Also, it can be beneficial to reach out to Gravity Forms directly as they are also collecting relevant Gravity Forms user information from their side as well.

I am experiencing the same error.

I am using CloudFlare on the website where Gravity Forms is installed.

Disabling Super Bot Fight Mode in Cloudflare did not fix the error for us.

If disabling Super Bot Fight Mode is fixing it for some users, I believe Zapier needs to look into whether or not this is a CloudFlare firewall related issue. If it is, users will need instructions as to what IP addresses or user agents should be whitelisted.

Badge

Hello @DancingQueen. I hear you and I get your frustration!

I’ve added you to the issue, so you’ll be notified once there is a solution. In the meantime, please do reach out to the Gravity Forms support team as the more customer data they can get - the more likely they can get a solution out to customers sooner. I know there’s been a ton of back and forth between Gravity Forms support and Zapier support trying to figure this out and your information helps.

This is absolutely outragiouse!

Can someone please take ownership of this matter and solve it to the benefit of all of us customers, paying both to Zapier and Gravity form, just to end up with two products that cannot work with each other?!

This is devastating for all business who are relying on this to WORK!

 

Please advise ASAP!

Userlevel 1
Badge

@john-rl You’ve been added to the report and you’ll be notified once we have a solution. We appreciate your patience!

Same issue, any status ?  The WP instance is set to auto update Gravity Forms plugin, so version should not be a problem.

Userlevel 1

In case you’re using CloudFlare and you are experiencing this issue, disable “Super Bot Fight Mode” and everything will work. 

 

This works for me thanks!

Userlevel 1

In case you’re using CloudFlare and you are experiencing this issue, disable “Super Bot Fight Mode” and everything will work. 

Userlevel 7
Badge +10

Everyone: So sorry for the frustrating experience with Gravity Forms and Zapier! Clearly neither us nor GF want this to be the experience for you all. 

I see a response on our bug tracking system from the GF team, quoting one of their users:

Before I started the debugging process i went into our Wordpress instance and upgraded to the latest x.x.24 release of Gravity Forms plugin and then in Zapier I retried reconnecting using the new website url and secret key and password and it worked! I've run a few tests and things seem to be submitting again.

Maybe trying that will help some of y’all as well! If not, there’s the following workaround...

@echo:

When you say that the webhooks workaround doesn’t work for you, do you mean what this this Community member suggested, to use the Gravity Forms webhook add-on with the catch hook option of Webhooks by Zapier?

Also, I see in the Gravity Forms changelog that they released an update 2 days ago. If you’ve been using the most recent version unsuccessfully, I’d be curious to know if that update has made a difference at all.

If you have not done so already, I’d recommend contacting both the Zapier and Gravity Forms support teams. They’ll have more tools at their disposal and can dig into logs to see what’s happening.

@Secafi and @NTCAdmin:

You’ve both been added to the list of affected users, and what I mentioned above for echo could apply to you as well: try the webhooks workround, see if the latest GF update helps at all, and get in touch with Zapier and GF support teams. It really does seem to be the case when GF digs in that the problem can be caused by different things, so I’d definitely recommend reaching out to their excellent support team.

Reply