Best answer

Gravity Forms Connection error

  • 11 March 2021
  • 68 replies


I keep getting Base URL invalid when try to connect Gravity forms app (Auth 2.0)


Best answer by nicksimard 2 August 2021, 19:27

Hey everybody! I wanted to post a quick update here that this issue has been closed. If you’re still running into problems, your best bet is to contact the Gravity Forms support team. They can troubleshoot the problem, including to see if you’re running the correct versions of WordPress, Gravity Forms and the Zapier Add-On.

View original

68 replies

Userlevel 6
Badge +6

Hi @Eyal,

Are you following this official walkthrough?


Yes, on other sites is work well.

Userlevel 7
Badge +10

Hi @Eyal!

Happy to see that you’ve reached out to our Support team and they’ve helped you out with this. 

For anyone else who finds this thread, here’s what Support had to say:

Invalid Base URL error looks to be a bug with this app. The good news is you're not the first user to report this problem and it's on our radar. I’ve added your name to this issue which does the following:

  • Re-raises the request with the dev team
  • Gives us a place to track users affected
  • Reminds us to notify you once this become available

I don’t have an ETA of when or if this will happen, but we will definitely email you when this is fixed! Keep an eye out for our Zapier Updates in your inbox.

It may be best to reach out to them if you run into this error, since it may not always be the case that it’s related to this bug.

Userlevel 1

Hi I am having the same issue.


authentication failed: Invalid Base URL.


I cannot connect the two.


So at the moment is it not possible to use Gravity Forms and Zapier?


I seem to be hitting the same issue with the authentication failed: Invalid Base URL.

I was able to connect gravity forms to without issue so I suspect the issue is with zapier specifically.

Userlevel 7
Badge +10

Hey @hdav and @Hottest DOg!

I’ve added you both to this bug report so when it gets resolved you’ll be notified via email. I see comments from the Gravity Forms teams saying that they’re looking into this. I suspect (and hope) it won’t be too much longer before this one’s fixed :)

Userlevel 1


I seemed to have fixed my issue. It turned out that I was getting invalid URL notifications because my wordpress site was pointing to a CDN used by Sitelock, who we use for extra security, and Sitelock were blocking the API. It was a bit of a mess for Sitelock whitelist the Zapier IPs as they use AWS and there’s hundreds of them, and could change in the future, and it let me set up the Zap, but wasn’t pulling the data through. In the end the actual fix was easy: get Sitelock to whitelist the ‘user agent’ for the API, which is literally just “Zapier”. Not sure if that will work for others, but it worked for me. 


Userlevel 1

Also having this issue, need this fixed as soon as possible.

Userlevel 1

I posted a reply about how I fixed mine - it was to do with my site using Sitelock CDN that was blocking the API, but not sure where the reply has gone

Userlevel 1

This might not work for you, because in my case my wordpress site is using Sitelock, which is pointing the domain to their CDN, and their firewall was blocking the connection. I went onto Sitelock’s support chat, and got them to whitelist the user agent name, which is literally ‘Zapier’ - and now it’s working. So the firewall will scan all API requests with the user agent name Zapier and let those ones through.

Not sure if that’s your case scenario - but worked for me

I’m encountering this issue as well. How do I sign up for updates?  @nicksimard 

Userlevel 7
Badge +10

Hi @ibro and @ryan_blip!

I’ve added you to the issue as well, so you’ll be updated when it’s resolved.

Hi, I’d also like updates on this issue. I’m looking to add a new form as soon as possible. Thank you!

Userlevel 7
Badge +8

Hi @BarVision - I’ve added you to this issue. You’ll be contacted via email if we have an update to share. Thanks!

Userlevel 1

Hi, Please add me to the list and let me know when the issue is resolved. Thanks!

Hi I have one Zap connected and running to one gravity form, I tried to connect a second one but now I am getting the “Invalid base URL” error message. It’s very important and urgent for us to fix this and connect both forms. Please let me know what can I do to fix it. Thank you in advance. 


I am having the same problem and would like to receive an update on when and how the issue is resolved.

Thank you!


Gravity Forms responded to me and said that they have NOT received communication on some of these issues. This makes it very confusing and hard to discern.  They’ve done some tests on their end, which passed, and told me that some of these problems are on Zapier’s end.  However, Zapier is not providing any details, test results, etc. 


By the way, Zapier said “no refund” while this doesn’t work.  I’m not too happy about that.


Also, in my interactions, Zapier says there is no timeline for a solution. This has me concerned, since my business largely depends on Zapier functionality.

Userlevel 7
Badge +11

@Airdev, @Home Painters and @jgamez I’ve added you all as affected users on the issue and you’ll get an email from us when it’s resolved. Thanks!

Userlevel 7
Badge +11

Hi @jupebox 

I can see that you’ve commented on both to this post and another one about the same issue


I replied to your comments on the other post and I’ll post part of my reply here, in case anyone would like more information:

The Gravity Forms Zapier integration is owned and maintained by them, which means that the Gravity Forms team will need to address this issue with their Zapier integration. We’re unable to give an estimate of when it will be fixed though I can see that the Gravity Forms team is working hard to find a solution to this issue.


I am having the same issue. My site is private (requires login to view) and it says invalid URL. I have a .co URL (not .com). I sent support an email with screenshots. What happened to being able to add the webhook in the Gravity Forms Zapier plugin? May have to move to if unable to connect.

Userlevel 7
Badge +7

@mduncan I see that you have reached out to Support who has added you to this report. They will be in touch with updates via email as they are available!


We are trying to connect Zapier and Gravity forms for the first time, and we are also running into this same error. Here is the message we get:

“We hit an error adding your new account

authentication failed: Invalid Base URL.

  1. Make sure you click "Allow" or "Accept" on the permission popup
  2. Double check your Account has the correct permissions
  3. Check out our help docs for more information”

Can we get this issue resolved?

Thank you!