Best answer

Google contacts to Hubspot not working

  • 17 March 2020
  • 6 replies
  • 49 views

Greetings, first attempt at a zap.  I am using a preconfigured one designed to pull new google contacts into hubspot. When setting it up:
 

  • It appears to accurately pull test contacts from Google Contacts under “Find Data”
  • It does not seem to be doing anything on the “Send Data” side. When I attempt to run a test in the set-up, I’m either doing it incorrectly or it’s not working. When I skip testing, run the zap, and conduct my own test by creating a new test contact in Google Contacts, nothing transfers to my Hubspot.

Help?? Thanks

icon

Best answer by Danvers 6 April 2020, 14:00

I’m sorry for the delay in getting back to you on this. ​

Taking a look at the screenshot of the task history that you sent, I can see that the amount of records returned by the trigger means that it fired our Flood Protection system. We have that in place to mainly protect your Task limit, so that an error in the trigger app doesn't use up all of your monthly Task allowance. It is also there as a layer of protection for our own infrastructure, as well.

​By default, this limit is set at 100.  More on this can be found here: https://zapier.com/help/troubleshoot/behavior/rate-limits-and-throttling-in-zapier#step-3

 

Did you add over 400 contacts to Google Contacts in one go? If so, you can safely hit the ‘Play 402’ button and the Zap will work through each contact one at a time. If you didn’t add that many contacts in one go, then it’s likely that another app or Zap is adding the contacts automatically, so you’ll want to check to make sure that you do want to add all of those contacts to HubSpot before you ‘Play’ the tasks. 

 

​I hope that's clear, please let me know if you have any questions!

View original

This topic has been closed for comments

6 replies

Userlevel 7
Badge +7

Hi @rjakious ,

Sorry you’re running into an issue with the Hubspot contact creation but congrats on building your first Zap!

When data isn’t passed, it’s often a result of an optional vs required value from the trigger step (read more here). Try double-checking that the email field within GoogleContacts is marked as required and let’s see if that does the trick. You can also read more about this integration here!

If the issue persists, let us know and we can dig deeper :slight_smile:

 

 

Thanks. I got the zap working….sort of. I can get it to send a contact or two through, but it seems like it stops working rather quickly.  One issue (perhaps related or perhaps a separate issue entirely) is that when I log into zapier there are over a thousand random zaps that are being held up.  It appears that it is trying to resend information that is already in Hubspot as though it’s a new or updated contact. (It’s not.)

 

Thanks.

Userlevel 7
Badge +11

Hi @rjakious! Could I ask if you have a Zap that’s also sending contacts from HubSpot to Google Contacts? In other words are you trying to sync in both direction?

If so, then it could be that you’ve created a Zap loop, where each Zap keeps triggering the other one. We have a guide on Zap loops if you’d like some more info on that.

 

If that’s not the case, can I check that I’ve understood what you said? You said that the Zap is successful a couple of times and then seems to stop and you have lots of tasks that are held. Could you take a screenshot of what that looks like so that we can better understand why it’s being held? And do you know if there’s another app that might be making updates to your contacts that’s causing the Zap to trigger?

It is the latter. Correct. Here are two screenshots

 

This seems like a pretty rudimentary zap. It clearly doesn’t work. It still doesn’t work...Hello? Help?

Userlevel 7
Badge +11

I’m sorry for the delay in getting back to you on this. ​

Taking a look at the screenshot of the task history that you sent, I can see that the amount of records returned by the trigger means that it fired our Flood Protection system. We have that in place to mainly protect your Task limit, so that an error in the trigger app doesn't use up all of your monthly Task allowance. It is also there as a layer of protection for our own infrastructure, as well.

​By default, this limit is set at 100.  More on this can be found here: https://zapier.com/help/troubleshoot/behavior/rate-limits-and-throttling-in-zapier#step-3

 

Did you add over 400 contacts to Google Contacts in one go? If so, you can safely hit the ‘Play 402’ button and the Zap will work through each contact one at a time. If you didn’t add that many contacts in one go, then it’s likely that another app or Zap is adding the contacts automatically, so you’ll want to check to make sure that you do want to add all of those contacts to HubSpot before you ‘Play’ the tasks. 

 

​I hope that's clear, please let me know if you have any questions!