Question

Facebook/Microsoft Dynamics 365 Custom Fields on Lead form not syncing

  • 10 February 2021
  • 6 replies
  • 31 views

We have two custom fields on the Dynamics 365 leads form - Programme and Campus.  We have added this onto our Facebook Leads form but it doesn't like the mapping/ Sync.  Looks like Zapier might have trouble handling this at present.  Is there a workaround for this, if so, can someone send a screenshot?  I have already sent Zaps through using the standard Leads fields in CRM and that works but not the custom ones (Lead does not appear when you add the custom fields).  It looks like its a GUID issue (CRM defines the fields as GUID’s and I think Zapier cannot match on this.


6 replies

Userlevel 7
Badge +11

Hi @BusinessMechanix!

 

Could I ask if Programme and Campus are custom entities in MS Dynamics 365, or fields within another entity?  I know that the integration doesn’t currently receive custom entity data, so it could be that.

Or do you mean that you can see the Dynamics 365 fields in the Zap editor, but you’re getting an error message when you try to add information from the Facebook Lead Ads form? 

Thanks!

Hi There, 

The programme and campus entities are custom entities in CRM, acutally they are technically custom fields which are added onto the leads form in CRM and are required fields.  We can actually see the fields in Zapier but cannot push data to them.  I suspect its becuase Zapier doesnt recognise Dynamics CRM GUIDs.  Looks like the error messaging has been updated since I gave up in October 2020, which is slightly more helpful by saying “ Note: There may be some fields missing because the Zap Editor does not currently support image fields nor unique identifier fields.”.  As you can see below, when I setup the Lead Ad, I can clearly see the Dynamics CRM fields through the Zapier integration, but you will see the unique identifier (GUID) for the field below the name.  This is where the Zap gets confused.  Its pretty irritating as its almost there...but not.  I can even select the dummy data field but when I click next to preview the selection prior to sending to CRM, you will see that the selected dummy data fields are then blanked out, which will error when you send to CRM and then we are back to the start as they are required fields so the Lead is rejected in Dynamics 365 CRM….any help much appreciated as I really need to get this working!  Thanks

 

 

 

Userlevel 7
Badge +10

HI @BusinessMechanix!

It looks like you haven’t submitted a test lead to that form, so you’re getting Facebook’s dummy sample data. Have you tried using the Facebook Lead Ads testing tool, as shown here: https://zapier.com/help/doc/common-problems-facebook-lead-ads#my-test-step-sample-doesnt-have-my-custom-form-fields.

This will let you send a form submission with real data. Can you see if that works for you?

Yes, I have tried submitting the Facebook Lead Ad using the form, I showed the screenshots above so you could see the issue with the GUID (the numbers shown against the Campus name).  This is what Dynamics CRM does with custom fields.  If you have a close look at the screenshots above you will see that Facebook cannot even generate dummy data for the custom fields either.  Basically custom fields on Dynamics 365 Lead Form don't work that are required fields in CRM  with Zapier Facebook Integration.  It works perfectly if I don't have the custom fields included.

 

Userlevel 7
Badge +11

Hi @BusinessMechanix 

This sounds really frustrating, I’m sorry about that. 

It sounds like the Support Team are best placed to help you with this one as they can take a closer look at the Zap and error with you. You can get in touch with them using the Get Help form

Userlevel 7
Badge +10

Hi @BusinessMechanix!

I wanted to check in with you on this one, since we didn't hear back after our last message. Did you still need help here or were you able to resolve things? Please let us know :)

Reply