Best answer

Error when connecting to SQL Server 2012 - special characters

  • 22 July 2020
  • 4 replies
  • 157 views

Userlevel 2

I am getting errors from the FreeTDS ODBC driver when trying to send text from Zapier to MS SQL Server 2012 (SP4-GDR).

If any special characters (such as æ, ø and å) which are regular characters in Danish and hard to avoid in address information, are sent. 

When using “Find Row via Custom Query” I get:

(pyodbc.ProgrammingError) ('42000', "[42000] [FreeTDS][SQL Server]Unclosed quotation mark after the character string 'K'. 

In this case because there is a text string that includes the letter ‘ø’ after the K. So FreeTDS cuts off the statement right when it meets the character and then thinks there was no closing quotation mark.

I don’t think I can control the Client Charset from within Zapier, since the driver sits at Zapier, but does anyone have an idea how I can fix this? 

icon

Best answer by steph.n 21 August 2020, 17:35

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +8

Hi there @BrightSun - Could you send a screenshot of the error that you’re seeing when you encounter this bug? It’d really help our team investigate further. Thanks!

Userlevel 2
Zapier error message

 

Userlevel 7
Badge +8

Hi @BrightSun - Sorry for the pause on this question. Someone else had the same question, and it looks like it’s a known bug. Here’s what Christopher from Zapier Support wanted to mention:

Thanks for writing back, I do fully appreciate the frustration and impact having a feature in Zapier not working can affect day-to-day business. It's not ideal at all and we want you to have the smoothest and most reliable experience in using Zapier.

I've taken this feedback to the team managing the app integration so they are aware of the impact the bug is having on your business.

At the moment, I am unable to offer another suitable workaround other than using the 'Find Row' action. Hopefully, the fix will come in soon, we'll be in touch by email once a resolution has been reached.

 

I’ve gone and added you to the bug report to have it investigated. Thanks!

Userlevel 2

Thank you very much for letting me know. I am glad that it is recognized as a bug :)