Do you have a problem with Facebook Lead Ad and GoToWebinar (400 Error)? – Here's the fix!

  • 17 April 2020
  • 1 reply
  • 236 views

Userlevel 1

Hi,

We have used a lot of Zaps that pull leads from Facebook Lead Ad to new registrants in GoToWebinar. 

Yesterday when we was creating a new Zap it stopped with this error “400 Error: Request contains invalid parameters. See validationErrorCodes for specific errors."

Now we have solved the problem and here's the solution:

  1. GoToWebinar has changed its field validation and Facebook Lead Ad dummy lead doesn't pass the validation anymore. Maybe because of the underlines and/or colons in firstname and lastname. 
  2. Example of Facebook dummy lead: test lead: dummy data for first_name | test lead: dummy data for last_name | test@fb.com
  3. How to fix it: Delete the dummy lead and create a new test lead from Facebook's "Preview Form" option (https://developers.facebook.com/tools/lead-ads-testing/). You can use your own details with a new test lead.
  4. When the custom lead is ready, find that data in your Zap: Facebook Lead Ad ("Find Data" phase) and use the same custom lead for GoToWebinar phase ("Send Data")
  5. Another solution is to use “SKIP TEST” option, but I think this one is more reliable because you can be sure that the new lead has moved successfully to GoToWebinar.

Now it works and hope this helps others too!


This topic has been closed for comments

1 reply

Userlevel 7
Badge +11

Thanks a lot for sharing this solution, John!