Best answer

Devops connection is throwing "Client secret is expired.".

  • 11 September 2020
  • 57 replies
  • 1987 views


Show first post
This topic has been closed for comments

57 replies

Userlevel 1

Hi there, I am experiencing the exact same error. Can you please advise ?

Userlevel 1

Signing on in another browser (the new Edge) and attempting the same process prompts to login to Azure (not surprisingly) but provides the following error;

 

 

I’m guessing Azure DevOps have updated their OAuth workflow :(

Userlevel 1

Hi guys, same problem being experienced here. I’ve removed the app from DevOps and from Zapier, but attempting to re-add the app into Zapier still shows the “Client secret is expired” error above.

Userlevel 1

Thank you @Liz_Roberts for the update

I have exactly the same issue :

 

Userlevel 7
Badge +7

Hi @naveen - sorry you are running into this! I suspect you may have stumbled across a current bug with the Azure DevOps app. I am escalating this to our Support team who can determine if this is the case and help to troubleshoot if not. 

Sit tight and someone will be in touch just as soon as they can!

Userlevel 2

HI Troy,

 Thanks for the reply. We are using the Azure Devops. I have generated a new client secret and now i don;t know how to update in Zapier to use this new secret key. I have deleted the existing connection and tried to add new one but still getting the same error.. Any idea where i can update the secret key in Zapier?

Userlevel 7
Badge +10

For Zapier App connections check here: https://zapier.com/app/connections

Click the TEST button to check an app.

You’ll likely need to update the Client Secret in the app that’s returning the error, then reauthenticate the app in Zapier.