Best answer

Devops connection is throwing "Client secret is expired.".

  • 11 September 2020
  • 57 replies
  • 1987 views


Show first post
This topic has been closed for comments

57 replies

We have the same issue.  Is there a resolution yet as this is really starting to hit us?  Our Zapier contract is about to expire and unless this is fixed it is no point renewing.

 

Darren

Please add me. 

 

We cannot proceed to evaluate Zapier to use it in upcoming important projects if this is not resolved.

Same issue here.

@Danvers 
Can you please add me to the affected user list as well? Thank you

Userlevel 1

While I prefer to see the actual problem solved, I did manage to set up a workaround that does exactly what my old zaps, using the Azure DevOps (AD) connector did.

The connector relies on setting up web hooks in the AD projects. Creating these hooks manually is however easily done under the AD project settings in the console (Project settings → General → service hooks)

Simply create a zap starting from a Zapier web hook that accepts a POST request. Use the Zapier hook URL to configure one or more web hooks in an AD project, and then complete the zap with the remaining logic from the faulty zap.

After communicating with Zapier support, they replied us that Microsoft are the owner of the Azure Integration and to create a ticket on their side. We created this bug, but we did not receive any other feedback than they are working on the issue and that they were able to reproduce it …

https://developercommunity.visualstudio.com/content/problem/1182247/zapier-azure-devops-integration-not-able-to-connec.html

I have the same issue.  I signed up for a trial specifically to test this connection before signing up, so now my trial is essentially useless until this is fixed. 

Hello there we are experiencing the same issue. Could you please let me know when it will be fixed?

this is affecting us as well

Userlevel 7
Badge +10

For Zapier App connections check here: https://zapier.com/app/connections

Click the TEST button to check an app.

You’ll likely need to update the Client Secret in the app that’s returning the error, then reauthenticate the app in Zapier.

Userlevel 2

HI Troy,

 Thanks for the reply. We are using the Azure Devops. I have generated a new client secret and now i don;t know how to update in Zapier to use this new secret key. I have deleted the existing connection and tried to add new one but still getting the same error.. Any idea where i can update the secret key in Zapier?

Userlevel 7
Badge +11

Hi @pictowolf, I’ve added you to the issue as well, thanks!

@Alfranklino@MartinTremblay@Gshell and @wikky I’ve added you all to the list of affected users. 

 

@Gshell I’m sorry that this is preventing you from making the most of your trial with Zapier. When this is resolved, if you contact the Support Team they’ll be able to give you some more time to try out Zapier. 

 

Hello @Gshell,

Thank you for your reply. I do not know if the issue only affects the users who are having trial accounts, but just in case, we are not in a trial period, and we are experiencing the same issue. Is the Support Team going to do something for those who purchased one of the Zapier paid plans?

Userlevel 7
Badge +11

Hi @Alfranklino 

I’m afraid we don’t offer discounts for such occurrences. We do work with our App Partners to ensure that issues with integrations that may come up are resolved as quickly as possible.

Thank you @Danvers for letting us know.

Please add me too as we are having the same issue with DevOps. We use Zapier to connect from SmartSheet to DevOps for software mod requests and this is a big deal for us.

Any help you can provide would be appreciated. I don’t want to have to go back and back these manually in DevOps .:nerd:

Kathy

Userlevel 1

I can confirm this is working again.  Thanks!!

We have the same issue.

Userlevel 1

@Liz_Roberts  Thank you Liz, I was not contacted by Zapier support though. Anything I should do?

@Zapier The lack of communication, ownership, and resolution is startling. As a company who recently deployed Zapier Teams, got one significant integration live, and was looking to expand our Zapier use to Azure DevOps, we are reevaluating our entire strategy. 

Hi,

I’m having the issue as well. This is blocking.

Any planned date on a fix ?

Have MS and Zapier managed to speak to each other ? (cf Enufacas comment here above)

Thanks

Userlevel 7
Badge +7

Thanks for letting us know, @Opisto ! It looks like Will reached out on 9/15 in response to your ticket. Could you please check your Spam folder to see if perhaps it got caught up there?

I do see that you have been added as an impacted user but want to make sure you’re receiving Zapier communication!

Userlevel 7
Badge +7

@Flightline Mike I’ve added you as an impacted user on this side as well!

Hi I tried to log in again with Azure DevOps account and I get the following error. 

 

Userlevel 7
Badge +7

Hi All,

It appears that this issue has been fixed! If you are still encountering any issues, you may need to contact our Support team so that they can assist!

Userlevel 1

Thank you @Liz_Roberts for the update

I have exactly the same issue :