Best answer

Data formatting zap step not changing date format correctly

  • 20 January 2022
  • 6 replies
  • 40 views

Userlevel 1

I am building a zap to trigger a new row in MySQL when I create a new record in Adalo. My issue is that Adalo stores their date in the format YYYY-MM-DDT00:00:00:000Z and MySQL store it as YYYY-MM-DD. 

 

As a result, I’ve created a zap action to change the format of the date input to one that works with MySQL.

 

The following two screenshots show this process in action with the date input, and the finished test with final date output.

 

I have set up the final step to populate the Date Created column in MySQL with the date output from the reformatting step (now it’s in the form YYYY-MM-DD)

However, when I run the final step I still receive the same error that the date created in MySQL cannot be of the format YYYY-MM-DDT00:00:00-05:00. The new row sent to MySQL shows a Date Created with the format YYYY-MM-DD. Any advice on how to address this issue and have the date formatting allow for a successful zap build is greatly appreciated.

 

icon

Best answer by Troy Tessalone 20 January 2022, 16:34

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +11

@Henrikcox 
Unfortunately, i think this could be considered a bug in the MySQL integration. Since the date_created field is a date field in Zapier, Zapier does some data manipulation to whatever you type in there to ensure its a date object prior to sending it in the request

I am curious though since it is a ‘date_created’ field. Is it required to send with your request or can MySQL automatically calculate it when the new record is created?

Userlevel 7
Badge +13

Hi @Henrikcox 

Try specifying a From Format:

 

Userlevel 1

Hi @Troy Tessalone, I just went ahead and tried filling the From Format input in the Date formatting action step. Unfortunately, it still seems like the end resulting error pops up, even when it looks like MySQL is being populated with the date in the format it wants to see it in.

 

 

Thank you for the insight @GetUWired; we have our MySQL table set up that unfortunately a new record for this collection does require a date created. If this field is blank it simply returns the error down below. I’m not sure if MySQL can calculate this automatically in any way.

 

Userlevel 7
Badge +13

@Henrikcox 

Might want to try opening a ticket with Zapier Support about this: https://zapier.com/app/get-help

Userlevel 1

Will do, thank you @Troy Tessalone 

Userlevel 7
Badge +8

Hi there, @Henrikcox! Thanks for reaching out!

I can see you’ve reached out to support, which is perfect. Please keep us posted! We’d love to hear any solutions ya’ll are able to uncover together.