Best answer

Connecting to Google Drive/Sheets "The app returned "Shared drive not found: My Google Drive"."


Userlevel 7
Badge +9

Hello! I’m tired, and I’m getting this error that I’ve never seen before when trying to use Google Sheets or Drive.

The app returned "Shared drive not found: My Google Drive".

Weirdly Google docs is working completely fine.

Anyone got any ideas, or is this one for support? I can’t Google this any longer :sweat_smile:

icon

Best answer by nicksimard 14 July 2020, 00:07

Hi @tian.luo!

Is this what you’re referring to: 

If so, we address that issue in this help doc: https://zapier.com/help/doc/common-problems-google-sheets-zapier#errors-when-using-a-custom-value-for-spreadsheet-or-worksheet-id

Does that look like what you’re experiencing?

View original

11 replies

Userlevel 7
Badge +9

Ok ...Error gone now. I have no solution. If I were to detail my steps:

  1. Hmm I’ve never seen that before - Blinks and tries again
  2. Nope - That doesn’t seem right
  3. Quick Google of error
  4. My settings ok? yep
  5. Quick Google of error again
  6. Maybe Google has done something? Nope
  7. Quick Google of error again - just in case
  8. Check my admin settings again
  9. Quick Google of error again  - The first two pages are purple
  10. Suck it up and ask the Community
  11. Quick Google of error again - Just to make sure
  12. Log out and back in again
  13. Check community - Has anyone answered?
  14. Quick Google of error again - Maybe I missed something
  15. It’s fixed

 

Userlevel 7
Badge +9

Now I’m getting this:

I’m going to bed

I’m getting a similar error for a zap that I’m trying to create from Typeform to Google Sheets...so frustrating as I’ve literally set up this same zap 100 times before without any issues… Anyone have any ideas how to fix this or is it just a bug? I sent support a message so hoping they get back to me ASAP.
 

 

I keep getting this message - is it a Google / Zapier bug - it’s very frustrating. Have connected, disconnected and reconnected multiple times, but not fixing this issue. 

Userlevel 7
Badge +9

Arvind from Zapier support updated with the solution:

I took a peek at the Zap and it looks like we're seeing this error message due to a recent issue with Google Sheets. We're currently investigating this and I've gone ahead and added you to the bug report so that you'll be immediately notified once it has been fully resolved.

In the meantime, we should be able to work around this by not selecting "My Google Drive" in the first dropdown field and then finish mapping the specific spreadsheet and worksheet IDs as custom values to their respective fields. You can find these IDs in your browser's address bar once you've opened the Sheet. Here's an example to help illustrate this:

Hey

Thanks a lot! I also tried this but at the end we faced the error message :( Any idea how to fix?

 

Arvind from Zapier support updated with the solution:

I took a peek at the Zap and it looks like we're seeing this error message due to a recent issue with Google Sheets. We're currently investigating this and I've gone ahead and added you to the bug report so that you'll be immediately notified once it has been fully resolved.

In the meantime, we should be able to work around this by not selecting "My Google Drive" in the first dropdown field and then finish mapping the specific spreadsheet and worksheet IDs as custom values to their respective fields. You can find these IDs in your browser's address bar once you've opened the Sheet. Here's an example to help illustrate this:

 

Userlevel 7
Badge +9

My honest answer would be “Use Airtable instead of Google docs for everything, and you will have a better life” :joy:

My actual answer is “no”. I’m sorry. Currently having other related issues too - I’ll keep you posted

Userlevel 1

Ok ...Error gone now. I have no solution. If I were to detail my steps:

  1. Hmm I’ve never seen that before - Blinks and tries again
  2. Nope - That doesn’t seem right
  3. Quick Google of error
  4. My settings ok? yep
  5. Quick Google of error again
  6. Maybe Google has done something? Nope
  7. Quick Google of error again - just in case
  8. Check my admin settings again
  9. Quick Google of error again  - The first two pages are purple
  10. Suck it up and ask the Community
  11. Quick Google of error again - Just to make sure
  12. Log out and back in again
  13. Check community - Has anyone answered?
  14. Quick Google of error again - Maybe I missed something
  15. It’s fixed

 

Very similar process! Clicked on the worksheet I wanted to use in the zap again and now seems to be working completely fine.

 

It was working fine yesterday morning & I added in a couple of new worksheets in the file with a query formula coming off of it. Seemed to be possibly be linked as the old worksheet wouldn’t work after I done that (but the new worksheets worked fine?)

I’m having the same issue as the person in the thread above. I’m triggering off of a new Typeform response, and creating a new spreadsheet by cloning an existing sheet, and then trying to add a row to the newly created sheet, which requires referencing that new sheet’s ID dynamically. 

Has there been any traction to this issue? This feels like a pretty big gap for a very common use case.

Userlevel 7
Badge +10

Hi @tian.luo!

Is this what you’re referring to: 

If so, we address that issue in this help doc: https://zapier.com/help/doc/common-problems-google-sheets-zapier#errors-when-using-a-custom-value-for-spreadsheet-or-worksheet-id

Does that look like what you’re experiencing?

All who may be concerned,

 

I was able to work around this issue, the only limitation I have is that all data must be contained inside one sheet (you can have as many worksheets as you like). Select your Spreadsheet, DO NOT use the ID stated above.Then you select the worksheet as well, same deal NO ID! Fill in the fields with your custom fields (I used text from the Formatter) just the same way Andy said and push through a test, should go over smoothly. Then populate the worksheet ID field with a custom choice. You’ll receive the error about the extra fields, blah blah. Just send through a new test and you should be transferring data from one WORKSHEET to another. :sunglasses:  (REMEMBER HAS NOT BEEN TESTED THOROUGHLY WITH SPREADSHEET TRANSFERS)

Reply