Best answer

Connecting sheets to webflow, the item field on the web flow side....what goes here? getting a 400

  • 9 March 2020
  • 4 replies
  • 370 views

Userlevel 2

Hey Zaps.

I am trying to connect google sheets to webflow.

The idea is to populate data ( numbers ) in google sheets which is pushed through to webflow CMS and displayed on a site web page.

Google sheets and webflow are connected in zapier & Google sheets is pulling in the data when doing a test.

When I test the webflow connection I am getting a 400 error - I am not sure which field is causing the error but there is an "item" field which is "required" - I havnt set anything like that in my google sheets and I am not sure what goes here. To troubleshoot I reduced the sheets to just one column and two rows, a header number and a field but still not working.

Understanding what should go in the "item" field might solve the problem.

Thanks


icon

Best answer by jesse 11 March 2020, 11:55

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +11

Hi @Andrew_K - I'm sorry your having trouble with your Zap, let's see if we can figure this out 🙂

Are there any fields in the Webflow step of the Zap that don't have anything in them? If you look at the Customize part of the Webflow steps, are there any fields there that say 'Required that don't have any information in them? If so, you'll need to make sure that there's something in there.

If you're not sure, could you please share a screenshot of the step (the 'Customize' part) so that we can see the fields it's asking for and what you have in them right now.


Userlevel 2

Hi Danvers,


Thanks for looking into this. In the two side of this zap we have the GET & POST.

GET - pulling data from google sheets seems to be working and can be displayed in the test pull on the zapier platform.

POST - pushing it onto webflow is where it is breaking down with a 400 error.

In the fields - the one that I don't know what to enter is labled "Item" and it is flagged as required - I dont have a field like this on my google sheets and I am not sure what to enter here. I've tried all the avalible answers from the drop-down but none seem to work.

Let me know if there is anything else you think I should try or other info I can supply.

Andrew


paste03.jpg


Userlevel 7
Badge +8

Hey @Andrew_K so this is a bit of a tough one.

According to Webflow's API, reference fields need the id of the item. So, instead of providing the "name" of the item, Webflow is expecting something more along the lines of "578cb0d518f10cd163af6571"

If the Zap sends the name of the item, it will result in the 400 error you're getting. Unfortunately, there isn't a way to retrieve the id from the Webflow UI so you'll have to make an API call to retrieve a list of Item IDs, insert a step between your existing steps to lookup items ID by name and return the IDs (either using a Formatter Lookup Table or Google Sheets "Find Row" action) and then map that output into the "Item" field on your Webflow action.

Sorry there isn't an easier workaround here! I've added you to an open feature request for this so the Webflow team is aware of your interest but so long as the Webflow API is structured as it is, I'm afraid we aren't able to get around this any other way at this time.


Userlevel 2

Hey Thanks Jesse,


Big thanks for digging in there ...but In a word..bugger! might just kill the dream and put the thing on-hold until we have a full DB running off AWS or something. I'll dig around looking for an ID on webflow- but if it isnt exposed in the UI, I think I'll need to wait on a change from Webflow, and be zapping elsewhere.


Great support. Thanks again.