Question

Can’t select Mailchimp workflow campaign

  • 22 July 2021
  • 9 replies
  • 26 views

I’m trying to set up a Zap between Mailchimp and Iris CRM to create new leads. I’m using a workflow automation in Mailchimp with three separate emails over 2 weeks. Zapier doesn’t show any campaigns available as a trigger. Is this because they are programmed in a workflow and not a standard email? I’ve sent the email out already so there is a test subscriber available. How do I get the campaign to display as an option in the Zap trigger?


9 replies

Userlevel 7
Badge +11

Hi @JessWachen 

Can you please post screenshots of how your Zap steps are configured?

If you’re trying to have a Mailchimp Customer Journey automation be triggered, then consider using a Mailchimp Tag to fire the workflow in Mailchimp to send the emails.

 

I have a Mailchimp customer journey running. When a subscriber opens an email from the journey, or clicks a specific link, I want that to activate a zap and send their info to Iris CRM. The campaign isn’t even appearing as an option in the Zap.

 

 

Userlevel 7
Badge +11

Hi @JessWachen 

Can you confirm you have link click tracking ON for the Mailchimp Campaign in question?

https://mailchimp.com/help/enable-and-view-click-tracking/

https://mailchimp.com/help/troubleshooting-click-tracking/

Yes, link tracking is on and Mailchimp has click and open data for this campaign.

Userlevel 7
Badge +11

@JessWachen 

Try sending a test email and clicking on the desired link(s), then try refreshing the Zap field options.

Yes, I’ve tried that several times.

Userlevel 7
Badge +11

@JessWachen 

Might be worth opening a ticket with Zapier Support: https://zapier.com/app/get-help

Userlevel 5
Badge +8

Hey @JessWachen,

It looks as though you’ve reached out to our Support team and they’ve added you to an existing feature request to have support for automated Mailchimp campaigns added.

We can’t confirm an ETA on when this would be supported in the Mailchimp integration. But we will notify you by email, and in the thread here, as soon as it is! :)

Thanks for adding the feature request. It looks like a similar request was being worked on a year ago, so I won’t hold out any hope of this being resolved any time soon.

Reply