Best answer

AWS RDS (Mysql) problem connection

  • 14 December 2020
  • 12 replies
  • 157 views

Userlevel 1

I'm trying connect de MYSQL plugin (zapier) in my RDS Database (aws), but zapier return a error message: "authentication failed: Could not connect with **** and provided password. The response we got from the server is included below for debugging purposes. 255"

 

I cant find a solution for this error code.

My user, host and password are correct. And the IP 54.86.9.50/32 are enabled in my Security Group. In other integration products, the plugin works.

icon

Best answer by Danvers 18 December 2020, 14:33

Hi @Chris Colligan!

 

In this case, the issue was the version of MySQL being used. Here’s what our Support Team had to say:

This kind of "255" error is MySQL's way of saying that Zapier isn't able to connect with your version of MySQL. Currently, it's not possible for Zapier to connect with MySQL versions of 8.0+

 

Right now, it would only be possible for Zapier to connect with a database running an earlier version of MySQL. We do have a feature request open to add compatibility with later versions, let us know if you’d like to be added to that feature request!

View original

12 replies

Userlevel 7
Badge +8

Hi there @pedropsb - Before we dive in more into your issue, would you be able to reconnect your app in your My Apps? Please let us know what the outcome was and we’ll go from there. Thanks!

Userlevel 1

Hi, @steph.n 

I'm tried again, but the result can't change: "

authentication failed: Could not connect with ***** and provided password. The response we got from the server is included below for debugging purposes. 255"

Userlevel 7
Badge +8

Hi @pedropsb - Our support team will be with you shortly about the error. Please watch for their outreach in your inbox. Thanks!

@steph.n @pedropsb Was there a resolution to this issue?

Userlevel 7
Badge +11

Hi @Chris Colligan!

 

In this case, the issue was the version of MySQL being used. Here’s what our Support Team had to say:

This kind of "255" error is MySQL's way of saying that Zapier isn't able to connect with your version of MySQL. Currently, it's not possible for Zapier to connect with MySQL versions of 8.0+

 

Right now, it would only be possible for Zapier to connect with a database running an earlier version of MySQL. We do have a feature request open to add compatibility with later versions, let us know if you’d like to be added to that feature request!

Hi Danvers,

 

Can you please also add me to the feature request as well. I am also struggling with the same.

Guys, this feature is important for us as well. Please, add us to this feature request.

We've been using Zapier for quite a long time. We upgraded our database to MySQL v8.0 and we lost a bunch of our automations performed using ZAPIER.

Does anyone know any workaround?

Userlevel 7
Badge +10

Hi @Maaz and @Tiago, from Cloudia.com.br!

I’ve gone and added you to the feature request, so you’ll receive an email notification when this has been implemented.

Userlevel 1

Yes please add me to the list as well. support for mysql 8+ is critical to our organization. 

Userlevel 7
Badge +7

@augustgermar I have added you as well. 

Userlevel 1

thank you

We have the same issue, 

would be great if you add us as well. @Liz_Roberts 

 

Our engine version is: 8.0.20

Reply