Best answer

ActiveCampaign Double Firing Trigger

  • 25 March 2020
  • 2 replies
  • 63 views

Userlevel 2
Badge

I have a chrome extension that sends data from a facebook group to a database, then that data is sent via API to Activecampaign.

Trigger is “new user added to list” 

7 or 8 times out of 10, it is firing twice in a row. Doesn’t appear to be adding twice with my API.

Has anybody else experienced this or do I need to report this as an issue?

icon

Best answer by Danvers 26 March 2020, 12:17

Hi @Robert_Segelquist!

 

We do often see some Active Campaign triggers fire twice for the same event. We’re working with Active Campaign to understand why this happens and how best to mitigate that. The first thing that I would suggest is to look very closely at the data you get from two triggers to see if there’s any field that is different. If there is, then you can use that field in a Filter step so that in the future, the Zap will only continue for one of the triggers. 

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +11

Hi @Robert_Segelquist!

 

We do often see some Active Campaign triggers fire twice for the same event. We’re working with Active Campaign to understand why this happens and how best to mitigate that. The first thing that I would suggest is to look very closely at the data you get from two triggers to see if there’s any field that is different. If there is, then you can use that field in a Filter step so that in the future, the Zap will only continue for one of the triggers. 

Userlevel 2
Badge

Thank you @Danvers. Luckily this is a one action zap and that action fails so it doesn’t cost any tasks, but good idea to add the filter if it was costing me multiple actions in the scheme of things!