Best answer

414 Error - URI too long????

  • 23 January 2020
  • 6 replies
  • 407 views

Userlevel 3

I'm trying to have Zapier find new contacts in Salesforce and then unsubscribe them from a Mailchimp list. Pretty simple! But I'm getting a 414 error saying the URI is too long.

I do not have a webhook in this zap, although I do have webhooks in other zaps also relating to Salesforce.

Does anyone know why I would be getting this error?



icon

Best answer by jesse 31 March 2020, 00:00

Hey @bestchance just wanting to followup here regarding the issue you were having! It looks as though our support team followed up with you and said that it seems the error message is mentioning that the URL used in the Salesforce trigger step is too long. We believe this may have to do with the Salesforce app version used in the Zap. If you update this to a New Record trigger with the newly improved Salesforce app, that may help.

a7dc128c7aa6f92134ede2fe89f7e437.png
(view larger)

If that didn’t help, please let us know and we can keep digging into this for you!

View original

This topic has been closed for comments

6 replies

Userlevel 7
Badge +9

Hi @bestchance and welcome to the Zapier community.

Which step is spitting out this error and can you post a screenshot of the error message here?

Most if not all apps on the Zapier platform are actually just webhooks in the background, so while you are not actually creating a webhook using the webhooks by Zapier app, the salesforce app and the mailchimp app are both using webhooks to communicate with their API to be able to get the data you are looking for or to change the data you want to change.


Userlevel 3

Thank you for responding Paul - I've been pulling my hair out over this one!!

Here is the screenshot. The error is actually in the first step of the (very simple!) zap. Would love some insight.

zap error 414.png


Userlevel 7
Badge +10

Hi @bestchance - with an error like that coming right at the trigger stage you'll need to get Zapier support involved. Send an email to contact@zapier.com and they'll help you out.

Also tagging @Danvers in case they can escalate you a bit quicker.


Userlevel 7
Badge +11

Hi @bestchance I've not seen this type of error before, so I'm going to escalate this to our Support team. You don't need to do anything and we'll be in touch as soon as we can.


Userlevel 3

Thank you all and thank you for the escalation @Danvers.

I had launched a ticket with Support on the 23rd but had not heard anything back. Really keen to resolve this as I've got a lot depending on getting this right! Thank you for looking into it.


Userlevel 7
Badge +8

Hey @bestchance just wanting to followup here regarding the issue you were having! It looks as though our support team followed up with you and said that it seems the error message is mentioning that the URL used in the Salesforce trigger step is too long. We believe this may have to do with the Salesforce app version used in the Zap. If you update this to a New Record trigger with the newly improved Salesforce app, that may help.

a7dc128c7aa6f92134ede2fe89f7e437.png
(view larger)

If that didn’t help, please let us know and we can keep digging into this for you!